summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2018-10-09 11:35:53 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-10-19 09:25:32 +0000
commitc26e9d029212626acb0b8dc7097f1e1b7e220a79 (patch)
tree612c8ef615a279188373f3246a5ef6e85e579a1c
parentb989aaed7b128cce0aaeb974c2561e9ee3cdf7a5 (diff)
Bump afb-test revision
Fix afm-test script installation 7b69512 Shellcheck: protect variable against whitespace abede0f Improve exit output message 1a33ac2 Test the LockWait feature 52f416b Unify test launch between target and native 25903e6 Update documentation cef21bd get rid of afb-definitions 02881ee Avoid to kill anything when no config file found 8de7f11 Separation between CB and classic test functions d2fbdb5 Rename test service api to be more discriminant. ca9049a Assert that an event hasn't been received 3db71f8 Script for both native and target launch Change-Id: Ic2b3d68cdb2b57613a0a24e42e43f307b2cae399 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
-rw-r--r--meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb b/meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb
index 906f59c3a..5cdd36560 100644
--- a/meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb
+++ b/meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb
@@ -6,8 +6,10 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
SECTION = "apps"
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/app-afb-test;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "bba4befcc57ff4eb106a01b416119da01accfcd1"
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/app-afb-test;protocol=https;branch=${AGL_BRANCH} \
+ file://run-ptest \
+ "
+SRCREV = "7b69512a0d4ed9b994ec02ed7f9ae004e9533d1f"
DEPENDS += "lua"
RDEPENDS_${PN} += "lua bash"
@@ -19,7 +21,7 @@ S = "${WORKDIR}/git"
inherit cmake aglwgt pkgconfig ptest
do_install_append() {
- install -d ${D}${bindir}
- install -m 775 ${B}/afm-test ${D}${bindir}/afm-test
+ install -d ${D}${bindir}
+ install -m 775 ${S}/afm-test.target.sh ${D}${bindir}/afm-test
}