summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2018-10-23 18:10:13 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2018-10-24 19:44:00 +0200
commitd7bc8762b59241610b2d5aab09b2b4e879de2be5 (patch)
tree81940630b93a5c25e14e76d87953e9b84e48b195
parent6685e02323e18ca11f10da0ac7db19239c28a14f (diff)
distro-build-manifest: Improve diagnostic messages
Change-Id: I684e30562cfda80abddd16195ec378a5f3e2dfba Signed-off-by: José Bollo <jose.bollo@iot.bzh>
-rw-r--r--meta-agl-profile-core/recipes-core/distro-build-manifest/distro-build-manifest.bb17
1 files changed, 16 insertions, 1 deletions
diff --git a/meta-agl-profile-core/recipes-core/distro-build-manifest/distro-build-manifest.bb b/meta-agl-profile-core/recipes-core/distro-build-manifest/distro-build-manifest.bb
index e42173888..0ef48b272 100644
--- a/meta-agl-profile-core/recipes-core/distro-build-manifest/distro-build-manifest.bb
+++ b/meta-agl-profile-core/recipes-core/distro-build-manifest/distro-build-manifest.bb
@@ -14,7 +14,7 @@ do_compile[nostamp] = "1"
do_compilestep1 () {
rc=99
outfile=${B}/platform-build-info
- if [ -f "${DISTRO_MANIFEST_GENERATOR}" -a -f "${DISTRO_SETUP_MANIFEST}" ]; then
+ if [ -x "${DISTRO_MANIFEST_GENERATOR}" -a -f "${DISTRO_SETUP_MANIFEST}" ]; then
${DISTRO_MANIFEST_GENERATOR} ${DISTRO_SETUP_MANIFEST} deploy >${outfile}-deploy
rc1=$?
${DISTRO_MANIFEST_GENERATOR} ${DISTRO_SETUP_MANIFEST} target >${outfile}-target
@@ -25,6 +25,21 @@ do_compilestep1 () {
if [ "$rc1" -ne 0 -o "$rc2" -ne 0 -o "$rc3" -ne 0 ]; then
rc=98
fi
+ else
+ if [ -z "${DISTRO_MANIFEST_GENERATOR}" ]; then
+ echo "The name of the generation script is not defined."
+ elif [ ! -f "${DISTRO_MANIFEST_GENERATOR}" ]; then
+ echo "Generation script ${DISTRO_MANIFEST_GENERATOR} is missing."
+ elif [ ! -x "${DISTRO_MANIFEST_GENERATOR}" ]; then
+ echo "Generation script ${DISTRO_MANIFEST_GENERATOR} isn't executable."
+ fi
+ if [ -z "${DISTRO_SETUP_MANIFEST}" ]; then
+ echo "The name of the data file is not defined."
+ elif [ ! -f "${DISTRO_SETUP_MANIFEST}" ]; then
+ echo "Data file ${DISTRO_SETUP_MANIFEST} is missing."
+ fi
+ echo "You can try to rerun aglsetup.sh to solve that issue."
+ echo "You can also try to source agl-init-build-env instead of oe-init-build-env."
fi
if [ "$rc" -ne 0 ]; then