aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2019-11-04 23:18:20 +0200
committerLeon Anavi <leon.anavi@konsulko.com>2019-11-06 13:45:16 +0200
commit0a620f5645d6dfb7485b4b869b96fd1257df9cbf (patch)
tree49257f6bb5931ab6a16a197b03b6e73ef6f42ad9
parent1d9673e260a7b612ef0f2df46155edd0d7da18d6 (diff)
bcm2835-bootfiles.bbappend: Update firmware
Update the firmware to support Linux kernel 4.19.80 for Raspberry Pi 3 B/B+ and 4. This way both the HDMI and the official 7" Raspberry Pi touch screen display are supported. Bug-AGL: SPEC-2465 Change-Id: Idb028b8abca5a44da2783def8af2c28f04de66d2 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
index 009c448bc..fc1ba88c3 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
@@ -1,12 +1,12 @@
RDEPENDS_${PN}_append_sota += " u-boot-otascript"
-RPIFW_DATE_raspberrypi4 = "20190709"
-SRCREV_raspberrypi4 = "356f5c2880a3c7e8774025aa6fc934a617553e7b"
-RPIFW_SRC_URI_raspberrypi4 = "https://github.com/raspberrypi/firmware/archive/${SRCREV}.tar.gz"
-RPIFW_S_raspberrypi_4 = "${WORKDIR}/firmware-${SRCREV}"
+RPIFW_DATE = "20191021"
+SRCREV = "ed238d3329e39a68bde03bbc2dfc293c0c3dc93a"
+RPIFW_SRC_URI = "https://github.com/raspberrypi/firmware/archive/${SRCREV}.tar.gz"
+RPIFW_S = "${WORKDIR}/firmware-${SRCREV}"
-SRC_URI_raspberrypi4 = "${RPIFW_SRC_URI}"
-SRC_URI[md5sum] = "${@ '5962784e7963f0116cd1519e47749b25' if d.getVar('MACHINE_ARCH') == 'raspberrypi4' else '5ccdb5447cbdd3ee0158a514f7b76cb9'}"
-SRC_URI[sha256sum] = "${@ '6e07d98e4229ba7a1970a4c475fc6b8631823d200d3b8734a508e7ff5ea4c120' if d.getVar('MACHINE_ARCH') == 'raspberrypi4' else '9a34ccc4a51695a33206cc6c8534f615ba5a30fcbce5fa3add400ecc6b80ad8a'}"
+SRC_URI = "${RPIFW_SRC_URI}"
+SRC_URI[md5sum] = "d18066531018a972ed927a6cc136cfff"
+SRC_URI[sha256sum] = "82048cf88f4f50f7cf83e34d93923ceb5147885761d33ee5f4dc980b4a7a426a"
-PV_raspberrypi4 = "${RPIFW_DATE}"
+PV = "${RPIFW_DATE}"