aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-11-12 22:22:57 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-11-17 15:22:46 +0000
commitec7a5daa1d7fd05b3eb562bc1491817fcd5922a3 (patch)
tree73f8f2fb056c05296ef2129bcd4f2582cd0f37f2
parentf4e36886785aa2a907db9577b52c6a7035826387 (diff)
agl-service-hvac: rework configuration file packaging
Move agl-service-hvac hvac.json configuration file install into its own recipe so that just it will be machine-specific, and replace m3ulcb-specific agl-service-hvac bbappend with a more generic do_install_append_ulcb in the new agl-service-hvac-conf recipe. Bug-AGL: SPEC-2949 Change-Id: Iabdfa2c204017a30bf82bed3eb6debbd3eb0be9c Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb27
-rw-r--r--meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb8
-rw-r--r--meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bbappend5
3 files changed, 30 insertions, 10 deletions
diff --git a/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb b/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb
new file mode 100644
index 000000000..e4dccbf3d
--- /dev/null
+++ b/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb
@@ -0,0 +1,27 @@
+SUMMARY = "HVAC Service Binding Configuration"
+DESCRIPTION = "AGL HVAC Service Binding Configuration"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-hvac"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-hvac;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install () {
+ install -D -m 644 ${S}/hvac.json ${D}${sysconfdir}/hvac.json
+}
+
+do_install_append_ulcb() {
+ sed -i -e "s#vcan0#sllin0#g" ${D}${sysconfdir}/hvac.json
+}
+
diff --git a/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb b/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb
index f5dc0814a..665e1ded4 100644
--- a/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb
+++ b/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb
@@ -13,10 +13,8 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
DEPENDS = "json-c"
-RDEPENDS_${PN} += "agl-service-identity-agent"
-
-do_install_append () {
- install -D -m 644 ${S}/hvac.json ${D}${sysconfdir}/hvac.json
-}
inherit cmake aglwgt pkgconfig
+
+RDEPENDS_${PN} += "agl-service-identity-agent"
+RRECOMMENDS_${PN} += "agl-service-hvac-conf"
diff --git a/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bbappend b/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bbappend
deleted file mode 100644
index 0817d5edd..000000000
--- a/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
-# for demo
-PACKAGE_ARCH_m3ulcb = "${MACHINE_ARCH}"
-do_configure_prepend_m3ulcb() {
-sed -i -e "s#vcan0#sllin0#g" ${S}/binding/hvac-demo-binding.c
-} \ No newline at end of file