summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2019-07-04 17:35:15 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-07-09 08:11:16 +0000
commit656b9cad0a96ff2baa76a12dea3ce298211dc4a8 (patch)
treed4615131dd8cde05f971b0d64724bf7e1781ea05
parent96372aab840abbed6b281f99c6dcb9d657c65fd2 (diff)
agl-service-hvac: Install hvac.json into /etc
agl-service-hvac has hvac.json file to set LED and CAN_DEV parameter, however this file is not installed. v2 move to main bb recipe file. fix wrong discription from WORKDIR to {S}. Bug-AGL: SPEC-2600 Change-Id: I8c0a416b3196b67cbb131d9351a1d20cc2dfe74f Signed-off-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
-rw-r--r--meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb b/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb
index dcd38c2a8..f5dc0814a 100644
--- a/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb
+++ b/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb
@@ -15,4 +15,8 @@ S = "${WORKDIR}/git"
DEPENDS = "json-c"
RDEPENDS_${PN} += "agl-service-identity-agent"
+do_install_append () {
+ install -D -m 644 ${S}/hvac.json ${D}${sysconfdir}/hvac.json
+}
+
inherit cmake aglwgt pkgconfig