summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2019-06-13 03:16:55 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-19 14:10:37 +0000
commit8724cde6d06a08955e1f2ce8e8bade3cc2ecdd18 (patch)
treea3f9e1257c12f08457addb5705336ce90b9d5225
parent1d1e623f1f74e7cebb8e2b4608200e2e0b05b8de (diff)
meta-agl-profile-core: recipes-connectivity: bluez: add notification status
Add 'notfication' reporting for the Status property via the org.bluez.obex.Message1 interface. Bug-AGL: SPEC-2512 Upstream-Status: PENDING Change-Id: Idce51acdc6f0718f07cc2bb669c4bc71686588ee Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
-rw-r--r--meta-agl-profile-core/recipes-connectivity/bluez5/bluez5/0001-obex-report-notification-status-on-incoming-message.patch26
-rw-r--r--meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend5
2 files changed, 30 insertions, 1 deletions
diff --git a/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5/0001-obex-report-notification-status-on-incoming-message.patch b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5/0001-obex-report-notification-status-on-incoming-message.patch
new file mode 100644
index 000000000..44bae715e
--- /dev/null
+++ b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5/0001-obex-report-notification-status-on-incoming-message.patch
@@ -0,0 +1,26 @@
+From 0d85faf308285c6a1f77f01660a2ce0541bfa5b4 Mon Sep 17 00:00:00 2001
+From: Matt Ranostay <matt.ranostay@konsulko.com>
+Date: Wed, 12 Jun 2019 17:04:00 -0700
+Subject: [PATCH] obex: report notification status on incoming message
+
+To match doc/obex.txt on incoming message notification the respective
+Status field should be set.
+---
+ obexd/client/map.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/obexd/client/map.c b/obexd/client/map.c
+index 550c5afb4..23be2d6b2 100644
+--- a/obexd/client/map.c
++++ b/obexd/client/map.c
+@@ -1914,6 +1914,7 @@ static void map_handle_notification(struct map_event *event, void *user_data)
+ switch (event->type) {
+ case MAP_ET_NEW_MESSAGE:
+ map_handle_new_message(map, event);
++ map_handle_status_changed(map, event, "notification");
+ break;
+ case MAP_ET_DELIVERY_SUCCESS:
+ map_handle_status_changed(map, event, "delivery-success");
+--
+2.20.1
+
diff --git a/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
index 1ab375645..736f18c79 100644
--- a/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
+++ b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
@@ -1,5 +1,8 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
-SRC_URI_append = " file://bluetooth.conf"
+SRC_URI_append = " \
+ file://bluetooth.conf \
+ file://0001-obex-report-notification-status-on-incoming-message.patch \
+"
do_install_append() {
install -m 0644 ${WORKDIR}/bluetooth.conf ${D}${sysconfdir}/dbus-1/system.d/bluetooth.conf