summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@gmail.com>2018-09-30 23:28:43 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-09-30 20:30:27 +0000
commit74a44338a407031c57ffd10eb03bf08074c699e3 (patch)
tree170b15e73d7431fdcfe0e7ca0c655187a69b15b5
parent9fe7ad39f8b78c4e912569b48781a535be38be14 (diff)
Use iperf3 instead of iperf2
iperf3 recipe is in meta-openembedded layer. Change-Id: I1c4f7345615f4ab99b1405a9ed53569ced1bdabe Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com>
-rw-r--r--meta-agl-profile-core/recipes-test/iperf/iperf-2.0.9/0001-fix-out-of-tree-config.patch52
-rw-r--r--meta-agl-profile-core/recipes-test/iperf/iperf-2.0.9/0002-fix-bool-size-m4.patch16
-rw-r--r--meta-agl-profile-core/recipes-test/iperf/iperf-2.0.9/iperf-2.0.5_ManPage.patch8
-rw-r--r--meta-agl-profile-core/recipes-test/iperf/iperf_2.0.9.bb20
-rw-r--r--meta-agl-profile-core/recipes-test/packagegroups/packagegroup-agl-test.bb2
5 files changed, 1 insertions, 97 deletions
diff --git a/meta-agl-profile-core/recipes-test/iperf/iperf-2.0.9/0001-fix-out-of-tree-config.patch b/meta-agl-profile-core/recipes-test/iperf/iperf-2.0.9/0001-fix-out-of-tree-config.patch
deleted file mode 100644
index e8a029790..000000000
--- a/meta-agl-profile-core/recipes-test/iperf/iperf-2.0.9/0001-fix-out-of-tree-config.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-iperf: fix out of tree configuration
-
-The configure step uses a package header to check for support of types/declares,
-this package header encapsulates all the required system header for providing
-the needed resources. When configured from an out of tree directory the package
-header is not found due to the hard path.
-We now make the path for package header relative to our 'srcdir' so it is
-found appropriately.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
-diff --git a/configure.ac b/configure.ac
-index 2b3fd20..d420f9e 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -176,8 +176,8 @@ dnl Check for system services
-
- dnl check for multicast
- if test "$ac_cv_multicast" != no; then
-- AC_CHECK_TYPES(struct ip_mreq,,,[#include "compat/headers_slim.h"])
-- AC_CHECK_DECLS(IP_ADD_MEMBERSHIP,,,[#include "compat/headers_slim.h"])
-+ AC_CHECK_TYPES(struct ip_mreq,,,[#include "${srcdir}/compat/headers_slim.h"])
-+ AC_CHECK_DECLS(IP_ADD_MEMBERSHIP,,,[#include "${srcdir}/compat/headers_slim.h"])
- AC_MSG_CHECKING(for multicast support)
- ac_cv_multicast=no
- if test "$ac_cv_have_decl_IP_ADD_MEMBERSHIP" = yes; then
-@@ -193,9 +193,9 @@ fi
-
- dnl check for IPv6
- if test "$ac_cv_have_ipv6" != no; then
-- AC_CHECK_TYPES(struct sockaddr_storage,,,[#include "compat/headers_slim.h"])
-- AC_CHECK_TYPES(struct sockaddr_in6,,,[#include "compat/headers_slim.h"])
-- AC_CHECK_DECLS(AF_INET6,,,[#include "compat/headers_slim.h"])
-+ AC_CHECK_TYPES(struct sockaddr_storage,,,[#include "${srcdir}/compat/headers_slim.h"])
-+ AC_CHECK_TYPES(struct sockaddr_in6,,,[#include "${srcdir}/compat/headers_slim.h"])
-+ AC_CHECK_DECLS(AF_INET6,,,[#include "${srcdir}/compat/headers_slim.h"])
- AC_MSG_CHECKING(for IPv6 headers and structures)
- ac_cv_have_ipv6=no
- if test "$ac_cv_type_struct_sockaddr_storage" = yes; then
-@@ -211,9 +211,9 @@ fi
-
- if test "$ac_cv_have_ipv6" = yes; then
- if test "$ac_cv_multicast" = yes; then
-- AC_CHECK_TYPES(struct ipv6_mreq,,,[#include "compat/headers_slim.h"])
-- AC_CHECK_DECLS(IPV6_ADD_MEMBERSHIP,,,[#include "compat/headers_slim.h"])
-- AC_CHECK_DECLS(IPV6_MULTICAST_HOPS,,,[#include "compat/headers_slim.h"])
-+ AC_CHECK_TYPES(struct ipv6_mreq,,,[#include "${srcdir}/compat/headers_slim.h"])
-+ AC_CHECK_DECLS(IPV6_ADD_MEMBERSHIP,,,[#include "${srcdir}/compat/headers_slim.h"])
-+ AC_CHECK_DECLS(IPV6_MULTICAST_HOPS,,,[#include "${srcdir}/compat/headers_slim.h"])
- AC_MSG_CHECKING(for IPv6 multicast support)
- ac_cv_have_ipv6_multicast=no
- if test "$ac_cv_type_struct_ipv6_mreq" = yes; then
diff --git a/meta-agl-profile-core/recipes-test/iperf/iperf-2.0.9/0002-fix-bool-size-m4.patch b/meta-agl-profile-core/recipes-test/iperf/iperf-2.0.9/0002-fix-bool-size-m4.patch
deleted file mode 100644
index 348e316ce..000000000
--- a/meta-agl-profile-core/recipes-test/iperf/iperf-2.0.9/0002-fix-bool-size-m4.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- iperf-2.0.5/m4/dast.m4.orig 2016-06-15 11:42:03.945581785 -0400
-+++ iperf-2.0.5/m4/dast.m4 2016-06-15 11:42:11.053581641 -0400
-@@ -11,7 +11,12 @@
-
- AC_DEFUN(DAST_CHECK_BOOL, [
-
--AC_CHECK_SIZEOF(bool)
-+if test "$ac_cv_header_stdbool_h" = yes; then
-+ AC_CHECK_SIZEOF(bool,,[#include <stdbool.h>])
-+else
-+ AC_CHECK_SIZEOF(bool)
-+fi
-+
- if test "$ac_cv_sizeof_bool" = 0 ; then
- AC_DEFINE(bool, int)
- fi
diff --git a/meta-agl-profile-core/recipes-test/iperf/iperf-2.0.9/iperf-2.0.5_ManPage.patch b/meta-agl-profile-core/recipes-test/iperf/iperf-2.0.9/iperf-2.0.5_ManPage.patch
deleted file mode 100644
index 12e8f4631..000000000
--- a/meta-agl-profile-core/recipes-test/iperf/iperf-2.0.9/iperf-2.0.5_ManPage.patch
+++ /dev/null
@@ -1,8 +0,0 @@
-diff --git iperf-2.0.5/man/Makefile.am iperf-2.0.5/man/Makefile.am
- index ed97bc6..728873f 100644
---- iperf-2.0.5/man/Makefile.am
-+++ iperf-2.0.5/man/Makefile.am
-@@ -1,2 +1 @@
--man_MANS = iperf.1
--dist_man_MANS = $(man_MANS)
-+dist_man_MANS = iperf.1
diff --git a/meta-agl-profile-core/recipes-test/iperf/iperf_2.0.9.bb b/meta-agl-profile-core/recipes-test/iperf/iperf_2.0.9.bb
deleted file mode 100644
index f297f7f7f..000000000
--- a/meta-agl-profile-core/recipes-test/iperf/iperf_2.0.9.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-DESCRIPTION = "Iperf is a tool to measure maximum TCP bandwidth, allowing the tuning of various parameters and UDP characteristics"
-HOMEPAGE = "http://dast.nlanr.net/Projects/Iperf/"
-SECTION = "console/network"
-LICENSE = "BSD-2-Clause"
-LIC_FILES_CHKSUM = "file://COPYING;md5=e8478eae9f479e39bc34975193360298"
-
-SRC_URI = " https://iperf.fr/download/source/${BP}-source.tar.gz \
- "
-
-SRC_URI[md5sum] = "1bb3a1d98b1973aee6e8f171933c0f61"
-SRC_URI[sha256sum] = "a5350777b191e910334d3a107b5e5219b72ffa393da4186da1e0a4552aeeded6"
-
-S = "${WORKDIR}/${BP}"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--exec-prefix=${STAGING_DIR_HOST}${layout_exec_prefix}"
-
-PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)}"
-PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
diff --git a/meta-agl-profile-core/recipes-test/packagegroups/packagegroup-agl-test.bb b/meta-agl-profile-core/recipes-test/packagegroups/packagegroup-agl-test.bb
index 1c3412e84..4591591e7 100644
--- a/meta-agl-profile-core/recipes-test/packagegroups/packagegroup-agl-test.bb
+++ b/meta-agl-profile-core/recipes-test/packagegroups/packagegroup-agl-test.bb
@@ -21,7 +21,7 @@ RDEPENDS_${PN} += "\
ffsb \
interbench \
iozone3 \
- iperf \
+ iperf3 \
ipv6connect \
linpack \
linus-stress \