summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-01-13 17:54:12 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-01-14 16:35:52 +0000
commit1d7769b7c0b379e68b46680a6dd3ebc4ab1e71a4 (patch)
treef0bbb91c531b794aa461afdaf70a3f6c066cda0e
parent318055748074b44261845d1a0a72901c1f1e6cab (diff)
meta-agl-profile-core: Add dev-mapping-ci recipe
Add a dev-mapping-ci recipe that installs a CI specific version of /etc/dev-mapping.conf for the agl-service-can-low-level binding. Additionally, the now required "j1939" bus mapping has been added to the default dev-mapping recipe's conf file. To enable use of the new recipe, the definition of the variable PREFERRED_RPROVIDER_virtual/low-can-dev-mapping has been updated in poky-agl.conf to enables it based on the AGLCI DISTRO_FEATURE. Bug-AGL: SPEC-3756 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ia980ed5e556bad9097ca0c305d1e26b21b10a9ac Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25908 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-distro/conf/distro/poky-agl.conf2
-rw-r--r--meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci/dev-mapping.conf.ci7
-rw-r--r--meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb18
-rw-r--r--meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default1
4 files changed, 27 insertions, 1 deletions
diff --git a/meta-agl-distro/conf/distro/poky-agl.conf b/meta-agl-distro/conf/distro/poky-agl.conf
index f6dc00d84..e418f4cdf 100644
--- a/meta-agl-distro/conf/distro/poky-agl.conf
+++ b/meta-agl-distro/conf/distro/poky-agl.conf
@@ -189,7 +189,7 @@ do_package_write_rpm[vardepsexclude] += "ARCHIVER_TOPDIR PF"
PREFERRED_RPROVIDER_virtual/navigation ?= "ondemandnavi"
# Set preferred provider for low-can device mapping configuration
-PREFERRED_RPROVIDER_virtual/low-can-dev-mapping ?= "dev-mapping"
+PREFERRED_RPROVIDER_virtual/low-can-dev-mapping ?= "${@bb.utils.contains('DISTRO_FEATURES', 'AGLCI', 'dev-mapping-ci', 'dev-mapping', d)}"
# Mask upstream meta-security bbappend that interferes with non-linux-yocto
# kernels due to the bug of having two wildcards, which bitbake does not
diff --git a/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci/dev-mapping.conf.ci b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci/dev-mapping.conf.ci
new file mode 100644
index 000000000..bd5c2135a
--- /dev/null
+++ b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci/dev-mapping.conf.ci
@@ -0,0 +1,7 @@
+; Default CAN device mapping
+; Format has to follow ini rules key="value", notice " around value.
+
+[CANbus-mapping]
+hs="vcan0"
+ls="vcan0"
+j1939="vcan0"
diff --git a/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb
new file mode 100644
index 000000000..cbba57308
--- /dev/null
+++ b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "AGL demo device mapping configuration file"
+DESCRIPTION = "This provides a default dev-mapping.conf file \
+ that defines mapping between kernel device and logical name \
+ used in the low-can binding for the AGL CI setup."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += "file://dev-mapping.conf.ci"
+
+inherit allarch
+
+do_install() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/dev-mapping.conf.ci ${D}${sysconfdir}/dev-mapping.conf
+}
+
+RPROVIDES_${PN} = "virtual/low-can-dev-mapping"
diff --git a/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default
index 7bd8bf2eb..8519a5873 100644
--- a/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default
+++ b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default
@@ -4,3 +4,4 @@
[CANbus-mapping]
hs="can0"
ls="can0"
+j1939="can0"