summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-03-31 19:37:09 -0400
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-04-27 17:12:24 +0200
commit4ae392ad605fd63f5ffdaaa567608322f77269df (patch)
tree6dfe96fcc17db02c3caa34caf3100206d8f79712
parentf397ae1d89fbe3a4bd4d72f03840bd5ddad189de (diff)
meta-agl-profile-core: update psplash for dunfell
Remove local systemd enablement changes for psplash in favor of using upstream support added in dunfell. Bug-AGL: SPEC-3302 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I13a4b2523fe869898b2ccede793afd0cdefbab88
-rwxr-xr-xmeta-agl-profile-core/recipes-core/psplash/files/psplash-anim11
-rw-r--r--meta-agl-profile-core/recipes-core/psplash/files/psplash-quit.service11
-rw-r--r--meta-agl-profile-core/recipes-core/psplash/files/psplash-start.service12
-rw-r--r--meta-agl-profile-core/recipes-core/psplash/psplash_git.bbappend22
4 files changed, 2 insertions, 54 deletions
diff --git a/meta-agl-profile-core/recipes-core/psplash/files/psplash-anim b/meta-agl-profile-core/recipes-core/psplash/files/psplash-anim
deleted file mode 100755
index ac9bf674a..000000000
--- a/meta-agl-profile-core/recipes-core/psplash/files/psplash-anim
+++ /dev/null
@@ -1,11 +0,0 @@
-#/bin/bash
-
-psplash-default "$@" &
-sleep .2
-while :; do
- for x in 0 1 2 3 4 5 6 7 8 9 10 -9 -8 -7 -6 -5 -4 -3 -2 -1 0 -1 -2 -3 -4 -5 -6 -7 -8 -9 10 9 8 7 6 5 4 3 2 1; do
- psplash-write "PROGRESS ${x}0" || exit 0
- psplash-write "MSG $(journalctl -n1 -ocat)" || exit 0
- sleep .1
- done
-done
diff --git a/meta-agl-profile-core/recipes-core/psplash/files/psplash-quit.service b/meta-agl-profile-core/recipes-core/psplash/files/psplash-quit.service
deleted file mode 100644
index 14bd4994b..000000000
--- a/meta-agl-profile-core/recipes-core/psplash/files/psplash-quit.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Terminate Psplash Boot Screen
-After=psplash-start.service
-
-[Service]
-Type=oneshot
-ExecStart=/usr/bin/psplash-write QUIT
-TimeoutSec=20
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-agl-profile-core/recipes-core/psplash/files/psplash-start.service b/meta-agl-profile-core/recipes-core/psplash/files/psplash-start.service
deleted file mode 100644
index d3b6940d0..000000000
--- a/meta-agl-profile-core/recipes-core/psplash/files/psplash-start.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=Start Psplash Boot Screen
-Wants=systemd-vconsole-setup.service
-After=systemd-vconsole-setup.service systemd-udev-trigger.service systemd-udevd.service
-DefaultDependencies=no
-
-[Service]
-ExecStartPre=/bin/sh -c "if [ -e /sys/class/graphics/fbcon/cursor_blink ]; then echo 0 > /sys/class/graphics/fbcon/cursor_blink; fi"
-ExecStart=/bin/bash -c "/usr/bin/psplash-anim -n -a 90"
-
-[Install]
-WantedBy=sysinit.target
diff --git a/meta-agl-profile-core/recipes-core/psplash/psplash_git.bbappend b/meta-agl-profile-core/recipes-core/psplash/psplash_git.bbappend
index bdc196b6f..5a82fc872 100644
--- a/meta-agl-profile-core/recipes-core/psplash/psplash_git.bbappend
+++ b/meta-agl-profile-core/recipes-core/psplash/psplash_git.bbappend
@@ -1,27 +1,9 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI += "file://psplash-colors.h \
- file://psplash-start.service \
- file://psplash-quit.service \
- file://psplash-anim \
- "
+SRC_URI += "file://psplash-colors.h"
SPLASH_IMAGES="file://psplash-poky-img.h;outsuffix=default"
-inherit systemd
-
-SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${PN}', '', d)}"
-SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'psplash-start.service psplash-quit.service', '', d)}"
-
do_configure_append () {
- cd ${S}
- cp ../psplash-colors.h ./
-}
-
-do_install_append () {
- if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
- install -d ${D}${systemd_unitdir}/system
- install -m 644 ${WORKDIR}/*.service ${D}/${systemd_unitdir}/system
- fi
- install -m 755 ${WORKDIR}/psplash-anim ${D}/${bindir}
+ cp -f ${WORKDIR}/psplash-colors.h ${S}
}