summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-06-24 17:47:43 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-06-24 17:48:35 +0200
commit54c2fda805fd7fda591008693cd6843413cee9f8 (patch)
tree16ab8f0ac5ba32e6741849eede7610bcfe844925
parent8e93c36104e8cd3f319170d70b60c705fd7fa402 (diff)
parent95b8edd4aab48f4cb66f3119e91e59ab74f907e9 (diff)
Merge the agl-compositor sandbox into master
The changes prepared by Marius for agl-compositor have been reviewed in the sandbox/mvlad/agl-compositor. This is the merge to master. Notes: - weston+ivi-shell+windowmanager are replaced using agl-compositor - applications have been adapted accordingly - CI will likely fail as we need to merge all related patches Updating 8e93c361..95b8edd4 Fast-forward meta-agl-bsp/conf/include/agl_rcar.inc | 11 ++++++++++ meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend | 4 ++-- meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb | 6 +++++- meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend | 7 +++--- .../recipes-platform/packagegroups/packagegroup-agl-graphical-weston.bb | 3 +-- meta-app-framework/recipes-core/af-main/af-main_git.inc | 2 +- templates/base/99_local.conf.inc | 14 ++++++++++++ templates/feature/agl-compositor/50_local.conf.inc | 48 ----------------------------------------- templates/feature/agl-compositor/README_feature_agl-compositor.md | 13 ----------- 9 files changed, 38 insertions(+), 70 deletions(-) Bug-AGL: SPEC-3444 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Change-Id: Iea2b7367fdf1c9874b4b76a016b9d1a181b0e791
-rw-r--r--meta-agl-bsp/conf/include/agl_rcar.inc11
-rw-r--r--meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend4
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb6
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend7
-rw-r--r--meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-weston.bb3
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_git.inc2
-rw-r--r--templates/base/99_local.conf.inc14
-rw-r--r--templates/feature/agl-compositor/50_local.conf.inc48
-rw-r--r--templates/feature/agl-compositor/README_feature_agl-compositor.md13
9 files changed, 38 insertions, 70 deletions
diff --git a/meta-agl-bsp/conf/include/agl_rcar.inc b/meta-agl-bsp/conf/include/agl_rcar.inc
index b88263f44..dd64ae772 100644
--- a/meta-agl-bsp/conf/include/agl_rcar.inc
+++ b/meta-agl-bsp/conf/include/agl_rcar.inc
@@ -29,6 +29,17 @@ DISTRO_FEATURES_append = " use_eva_pkg"
#DISTRO_FEATURES_append = " h265dec_lib mpeg2dec_lib"
DISTRO_FEATURES_append = " h264dec_lib h264enc_lib aaclcdec_lib aaclcdec_mdw"
+# Mask out meta-renesas-rcar-gen3's tweaks to weston-init, as they do
+# not seem necessary for anything in AGL, and the addition of
+# dbus.service and multi-user.target dependencies to the weston systemd
+# unit that is done is problematic with respect to potentially blocking
+# weston if any user units like application framework "platform"
+# services fail. They also likely affect boot up speed with respect to
+# getting weston started. There is no clear rationale expressed in the
+# meta-renesas-rcar-gen3 commit history for the extra dependencies, and
+# testing shows no issues on H3ULCB when not having them.
+BBMASK += "meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend"
+
IMAGE_INSTALL_append_rcar-gen3 = " \
kernel-devicetree \
kernel-module-pvrsrvkm \
diff --git a/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend b/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
index 6472c7eff..85ebc29d6 100644
--- a/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
+++ b/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
@@ -24,12 +24,12 @@ SRC_URI_append = "\
file://0010-Added-manifest-file-according-to-smack-3-domain-mode.patch \
"
-DEFAULT_WM_SHELL = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-compositor', 'xdg-shell', 'ivi-shell', d)}"
+AGL_DEFAULT_WM_SHELL ?= "xdg-shell"
AFM_CONF_DIR = "${D}${sysconfdir}/afm/unit.env.d"
QT_SHELL_FILE = "${AFM_CONF_DIR}/qt-shell"
do_install_append_class-target() {
mkdir -p ${AFM_CONF_DIR}
- echo "QT_WAYLAND_SHELL_INTEGRATION=${DEFAULT_WM_SHELL}" > ${QT_SHELL_FILE}
+ echo "QT_WAYLAND_SHELL_INTEGRATION=${AGL_DEFAULT_WM_SHELL}" > ${QT_SHELL_FILE}
echo "QT_WAYLAND_RESIZE_AFTER_SWAP=1" >> ${QT_SHELL_FILE}
}
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb b/meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb
index c0e2d9895..41f5f027b 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb
@@ -18,4 +18,8 @@ S = "${WORKDIR}/git"
inherit meson pkgconfig python3native
-FILES_${PN} = "${bindir}/agl-compositor ${datadir}/${PN}/protocols/agl-shell.xml ${datadir}/${PN}/protocols/agl-shell-desktop.xml"
+FILES_${PN} = " \
+ ${bindir}/agl-compositor \
+ ${datadir}/${PN}/protocols/agl-shell.xml \
+ ${datadir}/${PN}/protocols/agl-shell-desktop.xml \
+ "
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend b/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend
index ddabff5f5..374e9aa75 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend
@@ -2,9 +2,10 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
inherit agl-graphical
-WESTONSTART ??= "${@bb.utils.contains("DISTRO_FEATURES", "agl-compositor", "/usr/bin/agl-compositor", "/usr/bin/weston",d)} ${WESTONARGS}"
-WESTONSTART_append = " ${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", " --log=${DISPLAY_XDG_RUNTIME_DIR}/weston.log", "",d)}"
-WESTONSTART_append = " ${@bb.utils.contains("DISTRO_FEATURES", "agl-compositor", " --config ${sysconfdir}/xdg/weston/weston.ini", "",d)}"
+AGL_DEFAULT_WESTONSTART ??= "/usr/bin/agl-compositor --config ${sysconfdir}/xdg/weston/weston.ini"
+
+WESTONSTART ??= "${AGL_DEFAULT_WESTONSTART} ${WESTONARGS}"
+WESTONSTART_append = " ${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", " --log=${DISPLAY_XDG_RUNTIME_DIR}/compositor.log", "",d)}"
WIFILES = " \
file://weston.conf.in \
diff --git a/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-weston.bb b/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-weston.bb
index 35db34df9..2a4b22930 100644
--- a/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-weston.bb
+++ b/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-weston.bb
@@ -14,9 +14,8 @@ RDEPENDS_${PN} += " \
weston-init \
weston-ini-conf \
weston-examples \
- weston-ready \
agl-login-manager \
agl-desktop-config \
- ${@bb.utils.contains("DISTRO_FEATURES", "agl-compositor", "agl-compositor", "",d)} \
+ agl-compositor \
"
diff --git a/meta-app-framework/recipes-core/af-main/af-main_git.inc b/meta-app-framework/recipes-core/af-main/af-main_git.inc
index 3841dc30f..8e600c6c8 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_git.inc
+++ b/meta-app-framework/recipes-core/af-main/af-main_git.inc
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-main;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "f8cee78b734acf4636d134afa3f81ddcc06241e6"
+SRCREV = "ac6f7ed88291b81cb70981bd7463b6a3b292fece"
PV = "${AGL_BRANCH}+git${SRCPV}"
S = "${WORKDIR}/git"
diff --git a/templates/base/99_local.conf.inc b/templates/base/99_local.conf.inc
index 871ea0ebf..c4f43998b 100644
--- a/templates/base/99_local.conf.inc
+++ b/templates/base/99_local.conf.inc
@@ -17,3 +17,17 @@
# Additional free disk space created in the image in Kbytes.
#IMAGE_ROOTFS_EXTRA_SPACE="524288"
+# meta-agl/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend
+# AGL's compositor is started instead of weston like so
+# AGL_DEFAULT_WESTONSTART ?= "/usr/bin/agl-compositor --config ${sysconfdir}/xdg/weston/weston.ini"
+# you can redefine it using this variable to go back to weston,
+# but be careful that this needs further changes to work !
+# Especially the AGL demo apps will not work as-is.
+#AGL_DEFAULT_WESTONSTART = "/usr/bin/weston"
+
+# meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
+# This defines the QT integration. We default to xdg-shell
+# AGL_DEFAULT_WM_SHELL ?= "xdg-shell"
+# you can redefine it using this variable to e.g. use ivi-shell
+# but be careful that this needs further changes to work !
+#AGL_DEFAULT_WM_SHELL = ""
diff --git a/templates/feature/agl-compositor/50_local.conf.inc b/templates/feature/agl-compositor/50_local.conf.inc
deleted file mode 100644
index 48dd3a153..000000000
--- a/templates/feature/agl-compositor/50_local.conf.inc
+++ /dev/null
@@ -1,48 +0,0 @@
-DISTRO_FEATURES_append = " agl-compositor"
-
-# note that these are for testing only, should be removed once the changes
-# land in their respective repositories
-
-# shell client
-AGL_BRANCH_pn-homescreen = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-homescreen = "df79e3e5d9c6443d486c26fd98d48e0ca6fc95ef"
-DEPENDS_append_pn-homescreen = " wayland-native wayland qtwayland qtwayland-native"
-
-# normal apps
-AGL_BRANCH_pn-launcher = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-launcher = "83496d2f6968f7d12a183581d320065bdba52132"
-DEPENDS_append_pn-launcher = " wayland-native wayland qtwayland qtwayland-native"
-AGL_BRANCH_pn-hvac = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-hvac = "2afae8c55678cf070ee1a41137be48019ea4872c"
-DEPENDS_append_pn-hvac = " libafb-helpers-qt"
-AGL_BRANCH_pn-ondemandnavi = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-ondemandnavi = "10acae987db859bace7d2dcf4913a21073d65990"
-AGL_BRANCH_pn-mediaplayer = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-mediaplayer = "4518cdde5ddb053a4759f7b50f038c53bc41a45e"
-AGL_BRANCH_pn-alexa-viewer = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-alexa-viewer = "653a7eaf6db206b802b3a05f5a32f61815c9bf4b"
-DEPENDS_append_pn-alexa-viewer = " wayland-native wayland qtwayland qtwayland-native"
-AGL_BRANCH_pn-onscreenapp = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-onscreenapp = "98dab0eebc3dc0f567be3f80ab129cbcc71738db"
-AGL_BRANCH_pn-settings = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-settings = "ff650ab8c60a6cd218f4e981740ca41014cce7cc"
-
-# other apps
-AGL_BRANCH_pn-radio = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-radio = "1d542581205725de446376707dff7c31c61d04d8"
-AGL_BRANCH_pn-dashboard = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-dashboard = "ea01446bbc5a9bfe739da10869f08b0bd2e82174"
-AGL_BRANCH_pn-taskmanager = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-taskmanager = "516c53197ff82297ddf7ee1a55497f657e4abc19"
-AGL_BRANCH_pn-phone = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-phone = "e29b1f9d6d7b17645c4ab65250520b1df612fd7c"
-AGL_BRANCH_pn-poiapp = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-poiapp = "f7a0bc184e53ba5c756de079891d690eed0fc51e"
-AGL_BRANCH_pn-mixer = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-mixer = "b6638c65ad9af59abfb2a571e11be5a73dc662b8"
-AGL_BRANCH_pn-messaging = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-messaging = "eaa3566554111ad335cb73a219f920989ffcb70f"
-
-# use agl-service-homescreen
-AGL_BRANCH_pn-agl-service-homescreen = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-agl-service-homescreen = "79c9fb4fb8a8c8f6ebfbf0299f16e2ca4ddb56c6"
diff --git a/templates/feature/agl-compositor/README_feature_agl-compositor.md b/templates/feature/agl-compositor/README_feature_agl-compositor.md
deleted file mode 100644
index 4b5211ee7..000000000
--- a/templates/feature/agl-compositor/README_feature_agl-compositor.md
+++ /dev/null
@@ -1,13 +0,0 @@
----
-description: Feature agl-compositor
-authors: Daniel Stone <daniels@collabora.com>
----
-
-### Feature agl-compositor
-
-_agl-compositor_ is a new Wayland display server framework, based on the
-existing libweston library. It provides AGL users an extensible framework for
-window/input/output management within the display server.
-
-It is included as a technology preview, and is not currently ready for
-production use.