summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2024-12-05 14:46:24 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-12-13 11:54:09 +0000
commite8221d9757f0fca2042185377010c78bc9973b46 (patch)
tree1c050fb8762b561eef336e9acb2e5824931fb68d
parentb73b43d5ed0ddf127e263112a6200ce62cfb694f (diff)
agl-compositor-init-pipewire: Add a new package
That will enable both DRM+PipeWire backends. We depend on agl-compositor-ini as that contains the original systemd unit service, and it installs on its own a system drop in service file. Bug-AGL: SPEC-5235 Change-Id: I0a8319e979217275b1e29cc3aa6c12986639ddd8 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/30619 Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-compositor-init-pipewire.bb25
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-compositor-init/agl-compositor-pipewire.conf3
2 files changed, 28 insertions, 0 deletions
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-compositor-init-pipewire.bb b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init-pipewire.bb
new file mode 100644
index 000000000..d84475bf6
--- /dev/null
+++ b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init-pipewire.bb
@@ -0,0 +1,25 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/agl-compositor-init:"
+
+SUMMARY = "Startup systemd unit for the AGL Wayland compositor with starting in the same time the DRM and PipeWire backends"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+SRC_URI = "file://agl-compositor-pipewire.conf \
+"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}${systemd_system_unitdir}/agl-compositor.service.d
+ install -m644 ${WORKDIR}/agl-compositor-pipewire.conf ${D}/${systemd_system_unitdir}/agl-compositor.service.d/02-agl-compositor.conf
+}
+FILES:${PN} += "\
+ ${systemd_system_unitdir}/agl-compositor.service.d \
+ ${systemd_system_unitdir}/agl-compositor.service.d/02-agl-compositor.conf \
+ ${systemd_system_unitdir}/agl-compositor-stream-pipewire.service \
+ "
+
+RDEPENDS:${PN} = "agl-compositor-init weston-ini"
+RCONFLICTS:${PN} = "weston-init"
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-compositor-init/agl-compositor-pipewire.conf b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init/agl-compositor-pipewire.conf
new file mode 100644
index 000000000..aba0df102
--- /dev/null
+++ b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init/agl-compositor-pipewire.conf
@@ -0,0 +1,3 @@
+[Service]
+ExecStart=
+ExecStart=/usr/bin/agl-compositor -Bdrm,pipewire --idle-time=0 --config /etc/xdg/weston/weston.ini