summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-10-16 22:48:30 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-01-22 14:54:00 +0000
commitdabc6f23a00da9649900252f916a2f22cdc8d413 (patch)
tree57987c3b4bbdeedbcb0f2c58490dd00c25e101d7
parent2c0f2f6dbfab6df3c9ac34857811f052ec437c63 (diff)
waltham-transmitter-plugin: Add waltham-transmitter plug-in recipe
And remove waltham-transmitter_git recipe. v6 (mvlad): plain rebase to new folder structure (actually remove waltham-transmitter_git recipe). v5 (jsmoeller): plain rebase to new folder structure Bug-AGL: SPEC-3601 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: Ie18f1c8b91e5d7a222d38b2e451de6d045c1e3bd Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25455 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-core/recipes-graphics/wayland/waltham-transmitter-plugin.bb17
-rw-r--r--meta-agl-core/recipes-graphics/wayland/waltham-transmitter_git.bb34
2 files changed, 17 insertions, 34 deletions
diff --git a/meta-agl-core/recipes-graphics/wayland/waltham-transmitter-plugin.bb b/meta-agl-core/recipes-graphics/wayland/waltham-transmitter-plugin.bb
new file mode 100644
index 000000000..da46d06f9
--- /dev/null
+++ b/meta-agl-core/recipes-graphics/wayland/waltham-transmitter-plugin.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Waltham transmitter is a libweston plug-in that adds support for receiving input events from a surface streamed on a remote output"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/src/waltham-transmitter-plugin.git"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f21c9af4de068fb53b83f0b37d262ec3"
+
+DEPENDS += "wayland wayland-native waltham weston"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/waltham-transmitter-plugin.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "c9d23a045e6cb46c023c15f8189ef3ee8b1ddf20"
+
+S = "${WORKDIR}/git/"
+
+inherit meson pkgconfig python3native
+
+FILES_${PN} += "${libdir}/*"
+FILES_${PN} += "${bindir}/*"
diff --git a/meta-agl-core/recipes-graphics/wayland/waltham-transmitter_git.bb b/meta-agl-core/recipes-graphics/wayland/waltham-transmitter_git.bb
deleted file mode 100644
index 85f760709..000000000
--- a/meta-agl-core/recipes-graphics/wayland/waltham-transmitter_git.bb
+++ /dev/null
@@ -1,34 +0,0 @@
-DESCRIPTION = "Waltham is a network IPC library designed to resemble Wayland both protocol and protocol-API wise"
-HOMEPAGE = "https://github.com/waltham/waltham"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://waltham-transmitter/COPYING;md5=f21c9af4de068fb53b83f0b37d262ec3"
-
-DEPENDS += "libdrm virtual/kernel wayland wayland-native waltham weston gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad wayland-ivi-extension"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/weston-ivi-plugins.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "5287483228fa1e28f3217a54606cfe760c6582bd"
-
-S = "${WORKDIR}/git/"
-
-WALTHAM_PIPELINE_TRANSMITTER ?= "waltham-transmitter/waltham-renderer/pipeline_example_general.cfg"
-WALTHAM_PIPELINE_RECEIVER ?= "waltham-receiver/receiver_pipeline_example_general.cfg"
-WALTHAM_RECIEVER_IP ?= "192.168.1.2"
-WALTHAM_RECEIVER_PORT ?= "3440"
-
-inherit pkgconfig cmake
-
-do_install_append () {
- install -d ${D}/etc/xdg/weston/
- install ${S}/${WALTHAM_PIPELINE_TRANSMITTER} ${D}/etc/xdg/weston/transmitter_pipeline.cfg
- install ${S}/${WALTHAM_PIPELINE_RECEIVER} ${D}/etc/xdg/weston/receiver_pipeline.cfg
-
- sed -i -e "s/YOUR_RECIEVER_IP/${WALTHAM_RECIEVER_IP}/g" ${D}/etc/xdg/weston/transmitter_pipeline.cfg
- sed -i -e "s/YOUR_RECIEVER_PORT/${WALTHAM_RECEIVER_PORT}/g" ${D}/etc/xdg/weston/transmitter_pipeline.cfg
- sed -i -e "s/YOUR_RECIEVER_PORT/${WALTHAM_RECEIVER_PORT}/g" ${D}/etc/xdg/weston/receiver_pipeline.cfg
-
-}
-
-FILES_${PN} += "/etc/xdg/weston/*.cfg"
-FILES_${PN} += "${libdir}/*"
-FILES_${PN} += "${bindir}/*"