summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-05-30 14:47:34 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-06-01 08:38:04 +0000
commitff827503f54f4b1a9aad35c244b6585edc0eb41c (patch)
treeffe0f4017a8f831ef9b0b26c985fded1a18760c7
parent109051d8049fde31ca9421d6d590fef51131c01b (diff)
meta-agl-core: Rework packagegroup-agl-core-boot
To avoid the problem of it drift with respect to the upstream packagegroup-core-boot that it was originally derived from, rework packagegroup-agl-core-boot to just RDEPEND on it instead. This has the benefit of making the AGL additions more clearly visible. Additionally: - Define VIRTUAL-RUNTIME_base-utils-syslog for packagegroup-core-boot to match AGL's current default. - Add a VIRTUAL-RUNTIME_rngd variable to allow downstream users to remove or replace rng-tools in their distro configuration. - Explicitly add the packagegroup to IMAGE_INSTALL in the base agl-image-boot.inc to better match upstream core-image-minimal in definition, and make sure that any derived image that is created by including the inc file (instead of the bb file) is usable. Bug-AGL: SPEC-3932 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ib82d5d6b561eca4d059c56b01a0caddefcb48776 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26376 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account
-rw-r--r--meta-agl-core/conf/distro/poky-agl.conf2
-rw-r--r--meta-agl-core/recipes-platform/images/agl-image-boot.inc2
-rw-r--r--meta-agl-core/recipes-platform/packagegroups/packagegroup-agl-core-boot.bb34
3 files changed, 9 insertions, 29 deletions
diff --git a/meta-agl-core/conf/distro/poky-agl.conf b/meta-agl-core/conf/distro/poky-agl.conf
index 7689f049d..95b8fbec7 100644
--- a/meta-agl-core/conf/distro/poky-agl.conf
+++ b/meta-agl-core/conf/distro/poky-agl.conf
@@ -60,6 +60,8 @@ DISTRO_FEATURES_BACKFILL_CONSIDERED = "pulseaudio"
INIT_MANAGER = "systemd"
# Override default of "systemd-compat-units"
VIRTUAL-RUNTIME_initscripts = ""
+# Override default of "busybox-syslog"
+VIRTUAL-RUNTIME_base-utils-syslog = ""
# network manager to use (possible values: systemd, connman)
VIRTUAL-RUNTIME_net_manager = "connman"
diff --git a/meta-agl-core/recipes-platform/images/agl-image-boot.inc b/meta-agl-core/recipes-platform/images/agl-image-boot.inc
index 1c9ebda87..60d671bca 100644
--- a/meta-agl-core/recipes-platform/images/agl-image-boot.inc
+++ b/meta-agl-core/recipes-platform/images/agl-image-boot.inc
@@ -2,6 +2,6 @@ IMAGE_LINGUAS = " "
inherit core-image
-IMAGE_INSTALL = "${CORE_IMAGE_EXTRA_INSTALL}"
+IMAGE_INSTALL = "packagegroup-agl-core-boot ${CORE_IMAGE_EXTRA_INSTALL}"
IMAGE_ROOTFS_SIZE ?= "8192"
diff --git a/meta-agl-core/recipes-platform/packagegroups/packagegroup-agl-core-boot.bb b/meta-agl-core/recipes-platform/packagegroups/packagegroup-agl-core-boot.bb
index e4b540d79..2717dd153 100644
--- a/meta-agl-core/recipes-platform/packagegroups/packagegroup-agl-core-boot.bb
+++ b/meta-agl-core/recipes-platform/packagegroups/packagegroup-agl-core-boot.bb
@@ -11,37 +11,15 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
inherit packagegroup
-#
-# Set by the machine configuration with packages essential for device bootup
-#
-MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
-MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
-
-# Distro can override the following VIRTUAL-RUNTIME providers:
-VIRTUAL-RUNTIME_dev_manager ?= "udev"
-VIRTUAL-RUNTIME_keymaps ?= "keymaps"
-
-SYSVINIT_SCRIPTS = "${@bb.utils.contains('MACHINE_FEATURES', 'rtc', '${VIRTUAL-RUNTIME_base-utils-hwclock}', '', d)} \
- modutils-initscripts \
- init-ifupdown \
- ${VIRTUAL-RUNTIME_initscripts} \
- "
+# Disto can override
+VIRTUAL-RUNTIME_rngd ?= "rng-tools"
RDEPENDS_${PN} = "\
- base-files \
- base-passwd \
- ${VIRTUAL-RUNTIME_base-utils} \
- rng-tools \
- ${@bb.utils.contains("DISTRO_FEATURES", "sysvinit", "${SYSVINIT_SCRIPTS}", "", d)} \
- ${@bb.utils.contains("MACHINE_FEATURES", "keyboard", "${VIRTUAL-RUNTIME_keymaps}", "", d)} \
- netbase \
- ${VIRTUAL-RUNTIME_login_manager} \
- ${VIRTUAL-RUNTIME_init_manager} \
- ${VIRTUAL-RUNTIME_dev_manager} \
- ${VIRTUAL-RUNTIME_update-alternatives} \
- ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS}"
+ packagegroup-core-boot \
+ ${VIRTUAL-RUNTIME_rngd} \
+"
RRECOMMENDS_${PN} = "\
tzdata \
- ${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS}"
+"