summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-06-20 10:53:43 -0400
committerScott Murray <scott.murray@konsulko.com>2024-06-24 21:21:21 +0000
commit75c7354a09c17447e0aa04aab945d8d4ea0bae80 (patch)
tree66e816395367640480d1cfb84fd72fb6fc030204
parent46d21f682544e862b258dc1d1f0bfb27722a3fb0 (diff)
weston-ini-conf: do not enable gRPC proxy by default
Since building the agl-compositor gRPC proxy is only enabled when using meta-agl-demo, referencing it in the default Weston configurations when building meta-agl-core standalone is less than ideal. To avoid this, refactor the WESTON_FRAGMENTS variable to use a WESTON_FRAGMENTS_BASE variable for the non-display fragments, and drop "grpc-proxy" from it. The bbappend in meta-agl-demo can now just append it WESTON_FRAGMENTS_BASE to get the desired end result for the demo images. Bug-AGL: SPEC-5183 Change-Id: Ia351212023d1e426acc5be23a21b3de84660a024 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/30017 ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
index 574f89f2b..f6b27a14b 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
@@ -30,7 +30,8 @@ WESTON_DISPLAYS ?= "hdmi-a-1-90"
# Configuration fragments to use in weston.ini.*
# Note that some may be replaced/removed when building the landscape
# configuration.
-WESTON_FRAGMENTS = "core shell grpc-proxy ${WESTON_DISPLAYS}"
+WESTON_FRAGMENTS_BASE = "core shell"
+WESTON_FRAGMENTS = "${WESTON_FRAGMENTS_BASE} ${WESTON_DISPLAYS}"
# On-target weston.ini directory
weston_ini_dir = "${sysconfdir}/xdg/weston"