summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-08 15:35:37 -0400
committerScott Murray <scott.murray@konsulko.com>2022-06-14 04:44:42 +0000
commitd8761cb048b6c008b6e9ce53038b8a3a9986e84f (patch)
tree0f6dc0fa4241b0bca23294672befbd7483f7968e
parent004a9fedae45e51492011c5db80b7e96f42af772 (diff)
weston-ini-conf: rework remote output configuration generation
To allow for a user to change the weston-remoting configuration fragment the same way 8c4b3948 did with the the fragment for waltham-remoting, rename the TRANSMITTER* variables 8c4b3948 added to REMOTE* and apply the same transformations to the remote-output.cfg fragment. Additionally, add a new REMOTE_OUTPUT_APP_ID variable that will add the potentially required agl-shell-app-id option to the fragment if the variable is set. Bug-AGL: SPEC-4426 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ib20aafe5737482814fe6c4ae0f9cd1b39230adb3 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27619 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb25
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg.in (renamed from meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg)0
2 files changed, 17 insertions, 8 deletions
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
index c635d7b2f..89b216437 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
@@ -9,7 +9,7 @@ SRC_URI = " \
file://hdmi-a-1-90.cfg \
file://hdmi-a-1-180.cfg \
file://hdmi-a-1-270.cfg \
- file://remote-output.cfg \
+ file://remote-output.cfg.in \
file://transmitter-output.cfg.in \
file://virtual-0.cfg \
file://virtual-180.cfg \
@@ -32,16 +32,25 @@ WESTON_FRAGMENTS = "core shell ${WESTON_DISPLAYS}"
weston_ini_dir = "${sysconfdir}/xdg/weston"
# Options for the user to change in local.conf
-# e.g. TRANSMITTER_OUTPUT_MODE = "1080x1488"
-TRANSMITTER_OUTPUT_MODE ??= "640x720@30"
-TRANSMITTER_OUTPUT_HOST ??= "192.168.20.99"
-TRANSMITTER_OUTPUT_PORT ??= "5005"
+# e.g. REMOTE_OUTPUT_MODE = "1080x1488"
+REMOTE_OUTPUT_MODE ??= "640x720@30"
+REMOTE_OUTPUT_HOST ??= "192.168.20.99"
+REMOTE_OUTPUT_PORT ??= "5005"
+REMOTE_OUTPUT_APP_ID ??= ""
do_configure() {
- sed -e "s#mode=.*#mode=${TRANSMITTER_OUTPUT_MODE}#" \
- -e "s#host=.*#host=${TRANSMITTER_OUTPUT_HOST}#" \
- -e "s#port=.*#port=${TRANSMITTER_OUTPUT_PORT}#" \
+ sed -e "s#mode=.*#mode=${REMOTE_OUTPUT_MODE}#" \
+ -e "s#host=.*#host=${REMOTE_OUTPUT_HOST}#" \
+ -e "s#port=.*#port=${REMOTE_OUTPUT_PORT}#" \
${WORKDIR}/transmitter-output.cfg.in > ${WORKDIR}/transmitter-output.cfg
+
+ sed -e "s#mode=.*#mode=${REMOTE_OUTPUT_MODE}#" \
+ -e "s#host=.*#host=${REMOTE_OUTPUT_HOST}#" \
+ -e "s#port=.*#port=${REMOTE_OUTPUT_PORT}#" \
+ ${WORKDIR}/remote-output.cfg.in > ${WORKDIR}/remote-output.cfg
+ if [ -n "${REMOTE_OUTPUT_APP_ID}" ]; then
+ echo "agl-shell-app-id=${REMOTE_OUTPUT_APP_ID}" >> ${WORKDIR}/remote-output.cfg
+ fi
}
do_compile() {
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg.in
index f69a2e096..f69a2e096 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg.in