summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-11-28 20:44:17 +0000
committerScott Murray <scott.murray@konsulko.com>2022-12-13 18:42:39 +0000
commit330682b68d003dca793cb59cad07764c4115bdd8 (patch)
treed2e0c2d2f63f5d43952db4c066fcc6bd8890a1a4
parentda19d77913f9d4e93ee8b5cf847b68b2807cf582 (diff)
linux: config: move BBE-specific fragment from meta-agl-core to meta-agl-bsp
Commit d009fa0c42042a0b7d069779852953621e46469b as part of SPEC-4156 added a kernel config fragment to disable CONFIG_RELAY. Since this fragment is only applied to BBE, there's no need for it to reside in meta-agl-core and can be moved to meta-agl-bsp/meta-sancloud. Bug-AGL: SPEC-4156 Change-Id: I5da2632d6eb00bbf99ddb48cef861564d2ce868d Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28203 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> (cherry picked from commit 84ff0ab5cb380f1765fc13b2307b525873ad379b) Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28242 Reviewed-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-agl-bsp/meta-sancloud/recipes-kernel/linux/linux-bbe/disable-relay.cfg (renamed from meta-agl-core/recipes-kernel/linux/linux/disable-relay.cfg)0
-rw-r--r--meta-agl-bsp/meta-sancloud/recipes-kernel/linux/linux-bbe_%.bbappend1
-rw-r--r--meta-agl-core/recipes-kernel/linux/linux-agl-config.inc1
3 files changed, 1 insertions, 1 deletions
diff --git a/meta-agl-core/recipes-kernel/linux/linux/disable-relay.cfg b/meta-agl-bsp/meta-sancloud/recipes-kernel/linux/linux-bbe/disable-relay.cfg
index 09a117919..09a117919 100644
--- a/meta-agl-core/recipes-kernel/linux/linux/disable-relay.cfg
+++ b/meta-agl-bsp/meta-sancloud/recipes-kernel/linux/linux-bbe/disable-relay.cfg
diff --git a/meta-agl-bsp/meta-sancloud/recipes-kernel/linux/linux-bbe_%.bbappend b/meta-agl-bsp/meta-sancloud/recipes-kernel/linux/linux-bbe_%.bbappend
index b3709a24b..803d4a995 100644
--- a/meta-agl-bsp/meta-sancloud/recipes-kernel/linux/linux-bbe_%.bbappend
+++ b/meta-agl-bsp/meta-sancloud/recipes-kernel/linux/linux-bbe_%.bbappend
@@ -3,3 +3,4 @@ require recipes-kernel/linux/linux-agl.inc
FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
AGL_KCONFIG_FRAGMENTS += "cma-256.cfg"
+AGL_KCONFIG_FRAGMENTS += "disable-relay.cfg"
diff --git a/meta-agl-core/recipes-kernel/linux/linux-agl-config.inc b/meta-agl-core/recipes-kernel/linux/linux-agl-config.inc
index b3ac7373e..e8dfe5dbb 100644
--- a/meta-agl-core/recipes-kernel/linux/linux-agl-config.inc
+++ b/meta-agl-core/recipes-kernel/linux/linux-agl-config.inc
@@ -49,7 +49,6 @@ AGL_KCONFIG_FRAGMENTS += "sound.cfg"
# Enable support for SystemTap
AGL_KCONFIG_FRAGMENTS += "${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'systemtap.cfg', '', d)}"
-AGL_KCONFIG_FRAGMENTS:bbe += "disable-relay.cfg"
#
# Feature override and qemu specific appends: