summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-01-16 17:04:08 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-01-22 18:03:09 +0000
commit39def8ebd98c98e67304517ab118f9bde4cdf8e7 (patch)
tree0cfb21cab7d2408a4a7a665b662ee8b9373d4089
parentb7774b7b2710cb975f1c338e2dbfb5528322cfd4 (diff)
weston-ini-conf: make remote output configuration dynamic
Rework things to also update the remote output configuration fragment based on the value of TRANSMITTER_OUTPUT_HOST. This helps when using different IP addresses for e.g. the KVM demo configuration. Bug-AGL: SPEC-4618 Change-Id: I9b06f9b0be8d9ed3aaa6dd5e7d19f39c48329613 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28390 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb6
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg.in (renamed from meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg)0
2 files changed, 5 insertions, 1 deletions
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
index 53f7f4429..f99db39e5 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
@@ -9,7 +9,7 @@ SRC_URI = " \
file://hdmi-a-1-90.cfg \
file://hdmi-a-1-180.cfg \
file://hdmi-a-1-270.cfg \
- file://remote-output.cfg \
+ file://remote-output.cfg.in \
file://transmitter-output.cfg.in \
file://virtual-0.cfg \
file://virtual-90.cfg \
@@ -43,6 +43,9 @@ do_configure() {
-e "s#host=.*#host=${TRANSMITTER_OUTPUT_HOST}#" \
-e "s#port=.*#port=${TRANSMITTER_OUTPUT_PORT}#" \
${WORKDIR}/transmitter-output.cfg.in > ${WORKDIR}/transmitter-output.cfg
+ sed -e "s#host=.*#host=${TRANSMITTER_OUTPUT_HOST}#" \
+ -e "s#port=.*#port=${TRANSMITTER_OUTPUT_PORT}#" \
+ ${WORKDIR}/remote-output.cfg.in > ${WORKDIR}/remote-output.cfg
}
do_compile() {
@@ -59,6 +62,7 @@ do_compile() {
# and a corresponding landscape-inverted that is 180 degrees
# rotated.
rm -f ${WORKDIR}/weston.ini.landscape
+ rm -f ${WORKDIR}/weston.ini.landscape-inverted
for F in ${WESTON_FRAGMENTS}; do
INVF=$F
if echo $F | grep '^hdmi-a-1-\(90\|270\)$'; then
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg.in
index 940cbdd0c..940cbdd0c 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg.in