summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-11-23 16:33:29 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-12-14 16:28:38 +0000
commit89f3545d42b90e8b8ada5821e42134fd8beb5439 (patch)
treea9a7d11265804c3f064cb7339913632c6fc72ec1
parent9f6b5bd69119e9418a495f87ac523e76f649c732 (diff)
libsdl2: PACKAGECONFIG tweaks
Add a couple of bbappends for libsdl2 to tweak its PACKAGECONFIG, based on Panasonic QEMU+KVM documentation. Bug-AGL: SPEC-4618 Change-Id: I7ceb4e46faa88f09311ad359a3b0b13a462f6cb2 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28192 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account (cherry picked from commit 4255457f54a107e9399dd4834444191b855f7d44) Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28255 ci-image-boot-test: Jenkins Job builder account
-rw-r--r--meta-agl-core/recipes-graphics/libsdl2/libsdl2_%.bbappend1
-rw-r--r--meta-agl-core/recipes-graphics/libsdl2/libsdl2_aglcore.inc3
2 files changed, 4 insertions, 0 deletions
diff --git a/meta-agl-core/recipes-graphics/libsdl2/libsdl2_%.bbappend b/meta-agl-core/recipes-graphics/libsdl2/libsdl2_%.bbappend
new file mode 100644
index 000000000..48e50788e
--- /dev/null
+++ b/meta-agl-core/recipes-graphics/libsdl2/libsdl2_%.bbappend
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'aglcore', 'libsdl2_aglcore.inc', '', d)}
diff --git a/meta-agl-core/recipes-graphics/libsdl2/libsdl2_aglcore.inc b/meta-agl-core/recipes-graphics/libsdl2/libsdl2_aglcore.inc
new file mode 100644
index 000000000..7652e1843
--- /dev/null
+++ b/meta-agl-core/recipes-graphics/libsdl2/libsdl2_aglcore.inc
@@ -0,0 +1,3 @@
+# Make sure opengl is disabled, as using wayland implies gles2 in the
+# libsdl2 PACKAGECONFIG definitions.
+PACKAGECONFIG:remove = "opengl"