summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-01-17 12:47:59 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-01-22 18:03:09 +0000
commitb5001a4a5abbe8e7944446025dd63be725c491e4 (patch)
tree29655630189f904b86c35507aa9bcec5f6c1f9ee
parent69e119b969baa88594b3264709e21037aa783bb7 (diff)
meta-agl-bsp: make meta-rcar-gen3 BBMASKs more specific
Update the BBMASK definitions for the rcar3 platforms in meta-agl-bsp to include the meta-renesas/ component of the path so that they will not mask out any of our files under meta-agl-bsp/meta-rcar-gen3. Bug-AGL: SPEC-4618 Change-Id: I293d352605c55214d18c616e0fb544d20b4a8ab0 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28393 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-bsp/conf/include/agl_rcar-nogfx.inc4
-rw-r--r--meta-agl-bsp/conf/include/agl_rcar.inc2
2 files changed, 3 insertions, 3 deletions
diff --git a/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc b/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc
index c62b9d095..fb67fd976 100644
--- a/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc
+++ b/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc
@@ -44,10 +44,10 @@ PSEUDO_IGNORE_PATHS:append:pn-kernel-module-vspm = ",${KERNELSRC}"
# Mask out base-files and systemd bbappends to avoid changing systemd-tmpfiles
# behavior, see SPEC-4256 for a more involved explanation.
-BBMASK += "meta-rcar-gen3/recipes-core/base-files/ meta-rcar-gen3/recipes-core/systemd/"
+BBMASK += "meta-renesas/meta-rcar-gen3/recipes-core/base-files/ meta-renesas/meta-rcar-gen3/recipes-core/systemd/"
# Mask out cogl bbappend to avoid meta-gnome dependency
-BBMASK += "meta-rcar-gen3/recipes-graphics/cogl/cogl-1.0_1.%.bbappend"
+BBMASK += "meta-renesas/meta-rcar-gen3/recipes-graphics/cogl/cogl-1.0_1.%.bbappend"
# Provide default value that avoids errors from a new packaging QA
# check with respect to packagegroups depending on versioned library
diff --git a/meta-agl-bsp/conf/include/agl_rcar.inc b/meta-agl-bsp/conf/include/agl_rcar.inc
index da0819d71..e1169c21e 100644
--- a/meta-agl-bsp/conf/include/agl_rcar.inc
+++ b/meta-agl-bsp/conf/include/agl_rcar.inc
@@ -42,7 +42,7 @@ DISTRO_FEATURES:append:rcar-gen3 = " h264dec_lib h264enc_lib aaclcdec_lib aaclcd
# getting weston started. There is no clear rationale expressed in the
# meta-renesas-rcar-gen3 commit history for the extra dependencies, and
# testing shows no issues on H3ULCB when not having them.
-BBMASK += "meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend"
+BBMASK += "meta-renesas/meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend"
# Add graphics and decoder drivers to packagegroup-machine-base
# recommendation.