summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-09-10 13:07:20 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-09-21 13:18:34 +0000
commit1bb2a12e05f42d6522dfe8fdc9057334ce345264 (patch)
tree1dad85e730cb5b1df33b387772e42b3c6ff589b2
parent2e8dbab520652afa5e39e74793bdc917aa9ee86b (diff)
meta-app-framework: applaunchd: update for gRPC addition
Changes to facilitate building gRPC enabled versionm of applaunchd: - Bump SRCREV to pick up gRPC changes - Add required protobuf and gRPC dependencies to DEPENDS - Add new systemd unit for standalone gRPC API daemon Bug-AGL: SPEC-4559 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I21778f27b2eabd952e983b4571de05ad5d6c5af2 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27984 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-app-framework/recipes-core/applaunchd/applaunchd/applaunchd.service12
-rw-r--r--meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb11
2 files changed, 21 insertions, 2 deletions
diff --git a/meta-app-framework/recipes-core/applaunchd/applaunchd/applaunchd.service b/meta-app-framework/recipes-core/applaunchd/applaunchd/applaunchd.service
new file mode 100644
index 000000000..95673e962
--- /dev/null
+++ b/meta-app-framework/recipes-core/applaunchd/applaunchd/applaunchd.service
@@ -0,0 +1,12 @@
+[Unit]
+Wants=network.target
+After=network.target
+
+[Service]
+User=agl-driver
+Environment=XDG_DATA_DIRS=/usr/share
+ExecStart=/usr/bin/applaunchd
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb b/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
index e6439c3dd..d71714125 100644
--- a/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
+++ b/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
@@ -8,6 +8,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
DEPENDS = " \
glib-2.0 \
glib-2.0-native \
+ protobuf-native \
+ grpc-native \
+ grpc \
systemd \
"
@@ -15,21 +18,25 @@ PV = "2.0+git${SRCPV}"
SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/src/applaunchd;protocol=https;branch=${AGL_BRANCH} \
+ file://applaunchd.service \
file://agl-app@.service \
file://agl-app-web@.service \
file://agl-app-flutter@.service \
file://no-network.conf \
file://private-tmp.conf \
"
-SRCREV = "c675bafdf15cc19276bd8276c34f56404a5ecb62"
+SRCREV = "c52afaf8b5c96136fe20e5d5a1332121d3b09ee9"
S = "${WORKDIR}/git"
-inherit meson pkgconfig
+inherit meson pkgconfig systemd
+
+SYSTEMD_SERVICE:${PN} = "applaunchd.service"
do_install:append() {
# Install generic template for all agl-app services
install -d ${D}${systemd_system_unitdir}
+ install -m 644 ${WORKDIR}/applaunchd.service ${D}${systemd_system_unitdir}/
install -m 644 ${WORKDIR}/agl-app@.service ${D}${systemd_system_unitdir}/
install -m 644 ${WORKDIR}/agl-app-web@.service ${D}${systemd_system_unitdir}/
install -m 644 ${WORKDIR}/agl-app-flutter@.service ${D}${systemd_system_unitdir}/