summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-22 15:59:03 -0400
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>2024-07-03 09:06:50 +0000
commit96672393da820cca1ffbf68b1552a6bc56fafc4c (patch)
treec408a0254e88f502b4d6dd277ffbcbbfae8a58c8
parent2862349241054792cf2cd2f9c769ab87939f2ee5 (diff)
meta-agl-bsp: Remove obsolete Xen and SOTA recipes/bbappends
Remove Xen and SOTA related recipes and bbappends from the meta-agl-bsp dynamic-layers support since they are obsolete at this point, and this saves updating them for upstream changes such as the switch to UNPACKDIR. Bug-AGL: SPEC-5147 Change-Id: Ief491fbc766ccf7dcd98e4ee9e76a3d79e85f409 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot_xen.cmd45
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bbappend18
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript.bb32
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/boot.scr3
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.cma.txt21
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt21
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/renesas-ota-bootfiles.bb27
-rw-r--r--meta-agl-bsp/virtualization-layer/recipes-extended/xen/files/0001-XEN-on-RPi4-1GB-lmitation-workaround-XEN-tries-to-al.patch28
-rw-r--r--meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen-mkimage-rpi4.bb29
-rw-r--r--meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen-tools_git.bbappend11
-rw-r--r--meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen_git.bbappend18
11 files changed, 0 insertions, 253 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot_xen.cmd b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot_xen.cmd
deleted file mode 100644
index 24cfb1658..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot_xen.cmd
+++ /dev/null
@@ -1,45 +0,0 @@
-#
-# SPDX-License-Identifier: MIT
-#
-# Copyright (c) 2020, MERA
-#
-# Author: Leonid Lazarev
-#
-# Xen Boot Script
-#
-# https://www.raspberrypi.org/documentation/configuration/device-tree.md
-# We do not set fdt_addr, because device tree initially is loaded by raspberry pi firmware loader and the particular
-# modification are performed. The prepared DTS is propagated to u-boot and this prepared device tree has to be reused.
-
-setenv kernel_addr_r 0x00480000 # 16M
-setenv xen_addr_r 0x00200000 # 2M
-
-# Load xen to ${xen_addr_r}.
-fatload mmc 0:1 ${xen_addr_r} /xen-@@MACHINE@@
-
-#configure dom0
-fdt addr ${fdt_addr}
-
-#read prepared bootargs, rapsberry pi prepared initial list of the parameters for loading
-fdt get value bootargs /chosen bootargs
-fdt resize 8192
-
-# add device type for raspberry
-fdt set pcie0 device_type "pci"
-
-fdt chosen
-fdt set /chosen \#address-cells <1>
-fdt set /chosen \#size-cells <1>
-
-# Load Linux Image to ${kernel_addr_r}
-fatload mmc 0:1 ${kernel_addr_r} /@@KERNEL_IMAGETYPE@@
-
-# we load dom0 with 1512 MB of memory
-fdt mknod /chosen dom0
-fdt set /chosen xen,xen-bootargs "console=dtuart dtuart=/soc/serial@7e215040 sync_console dom0_mem=1512M bootscrub=0"
-fdt set /chosen xen,dom0-bootargs "${bootargs}"
-
-fdt set /chosen/dom0 compatible "xen,linux-zimage", "xen,multiboot-module"
-fdt set /chosen/dom0 reg <${kernel_addr_r} 0x${filesize} >
-
-@@KERNEL_BOOTCMD@@ ${xen_addr_r} - ${fdt_addr}
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bbappend
deleted file mode 100644
index 1e9f47d23..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bbappend
+++ /dev/null
@@ -1,18 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-
-SRC_URI:append =" \
- ${@bb.utils.contains('AGL_XEN_WANTED','1',' file://boot_xen.cmd','',d)} \
-"
-
-do_compile:append() {
-
- # if xen feature is activated we overwirte the boot script with xen specific one
- if [ "${AGL_XEN_WANTED}" = "1" ]; then
- sed -e 's/@@KERNEL_IMAGETYPE@@/${KERNEL_IMAGETYPE}/' \
- -e 's/@@KERNEL_BOOTCMD@@/${KERNEL_BOOTCMD}/' \
- -e 's/@@MACHINE@@/${MACHINE}/' \
- "${WORKDIR}/boot_xen.cmd" > "${WORKDIR}/boot.cmd"
-
- mkimage -A arm -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr
- fi
-} \ No newline at end of file
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript.bb b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
deleted file mode 100644
index ccaefc715..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
+++ /dev/null
@@ -1,32 +0,0 @@
-DESCRIPTION = "Boot script for launching OTA-enabled images on raspberrypi"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-DEPENDS = "u-boot-mkimage-native"
-
-COMPATIBLE_MACHINE = "raspberrypi"
-
-SRC_URI = "file://boot.scr \
- file://uEnv.txt \
- file://uEnv.cma.txt \
- "
-
-S = "${WORKDIR}"
-
-inherit deploy
-
-do_deploy() {
- install -d ${DEPLOYDIR}/bcm2835-bootfiles
-
- mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n "Ostree boot script" -d ${S}/boot.scr ${DEPLOYDIR}/bcm2835-bootfiles/boot.scr
- if [ "${ENABLE_CMA}" = "1" ]; then
- install -m 0755 ${S}/uEnv.cma.txt ${DEPLOYDIR}/bcm2835-bootfiles/uEnv.txt
- else
- install -m 0755 ${S}/uEnv.txt ${DEPLOYDIR}/bcm2835-bootfiles/uEnv.txt
- fi
-}
-
-addtask deploy before do_package after do_install
-do_deploy[dirs] += "${DEPLOYDIR}/bcm2835-bootfiles"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/boot.scr b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/boot.scr
deleted file mode 100644
index dc13f85b2..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/boot.scr
+++ /dev/null
@@ -1,3 +0,0 @@
-fatload mmc 0:1 $loadaddr /uEnv.txt
-env import -t $loadaddr $filesize
-run bootcmd
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.cma.txt b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.cma.txt
deleted file mode 100644
index 062bddb93..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.cma.txt
+++ /dev/null
@@ -1,21 +0,0 @@
-bootcmd_resetvars=setenv kernel_image; setenv bootargs; setenv kernel_image2; setenv bootargs2
-bootcmd_otenv=run bootcmd_resetvars; load mmc 0:2 $loadaddr /boot/loader/uEnv.txt; env import -t $loadaddr $filesize
-bootcmd_rollbackenv=setenv kernel_image ${kernel_image2}; setenv bootargs ${bootargs2}
-
-bootcmd_args=setenv bootargs "$bootargs $bootargs_fdt ostree_root=/dev/mmcblk0p2 root=/dev/ram0 rw rootwait rootdelay=2 ramdisk_size=8192 panic=1 coherent_pool=6M smsc95xx.turbo_mode=N"
-
-bootcmd_getroot=setexpr ostree_root gsub "^.*ostree=([^ ]*).*$" "\\\\1" "${bootargs}";
-
-bootcmd_fitconf=run bootcmd_getroot; if test -e mmc 0:2 "${ostree_root}/usr/lib/fit_conf"; then load mmc 0:2 $loadaddr "${ostree_root}/usr/lib/fit_conf"; env import -t $loadaddr $filesize; fi
-
-bootcmd_load=load mmc 0:2 $ramdisk_addr_r "/boot"$kernel_image
-bootcmd_run=bootm "${ramdisk_addr_r}${fit_conf}"
-
-bootcmd_create_envfile=if test ! -e mmc 0:1 uboot.env; then saveenv; fi;
-
-bootlimit=3
-
-bootcmd=if test "${rollback}" = "1"; then run altbootcmd; else run bootcmd_create_envfile; run bootcmd_otenv; run bootcmd_args; run bootcmd_fitconf; run bootcmd_load; run bootcmd_run; if ! "${upgrade_available}" = "1"; then setenv upgrade_available 1; saveenv; fi; reset; fi
-
-bootcmd_set_rollback=if test ! "${rollback}" = "1"; then setenv rollback 1; setenv upgrade_available 0; saveenv; fi
-altbootcmd=run bootcmd_create_envfile; run bootcmd_otenv; run bootcmd_set_rollback; if test -n "${kernel_image2}"; then run bootcmd_rollbackenv; fi; run bootcmd_args; run bootcmd_fitconf; run bootcmd_load; run bootcmd_run; reset
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt
deleted file mode 100644
index 436fe95fe..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt
+++ /dev/null
@@ -1,21 +0,0 @@
-bootcmd_resetvars=setenv kernel_image; setenv bootargs; setenv kernel_image2; setenv bootargs2
-bootcmd_otenv=run bootcmd_resetvars; load mmc 0:2 $loadaddr /boot/loader/uEnv.txt; env import -t $loadaddr $filesize
-bootcmd_rollbackenv=setenv kernel_image ${kernel_image2}; setenv bootargs ${bootargs2}
-
-bootcmd_args=setenv bootargs "$bootargs $bootargs_fdt ostree_root=/dev/mmcblk0p2 root=/dev/ram0 rw rootwait rootdelay=2 ramdisk_size=8192 panic=1"
-
-bootcmd_getroot=setexpr ostree_root gsub "^.*ostree=([^ ]*).*$" "\\\\1" "${bootargs}";
-
-bootcmd_fitconf=run bootcmd_getroot; if test -e mmc 0:2 "${ostree_root}/usr/lib/fit_conf"; then load mmc 0:2 $loadaddr "${ostree_root}/usr/lib/fit_conf"; env import -t $loadaddr $filesize; fi
-
-bootcmd_load=load mmc 0:2 $ramdisk_addr_r "/boot"$kernel_image
-bootcmd_run=bootm "${ramdisk_addr_r}${fit_conf}"
-
-bootcmd_create_envfile=if test ! -e mmc 0:1 uboot.env; then saveenv; fi;
-
-bootlimit=3
-
-bootcmd=if test "${rollback}" = "1"; then run altbootcmd; else run bootcmd_create_envfile; run bootcmd_otenv; run bootcmd_args; run bootcmd_fitconf; run bootcmd_load; run bootcmd_run; if ! "${upgrade_available}" = "1"; then setenv upgrade_available 1; saveenv; fi; reset; fi
-
-bootcmd_set_rollback=if test ! "${rollback}" = "1"; then setenv rollback 1; setenv upgrade_available 0; saveenv; fi
-altbootcmd=run bootcmd_create_envfile; run bootcmd_otenv; run bootcmd_set_rollback; if test -n "${kernel_image2}"; then run bootcmd_rollbackenv; fi; run bootcmd_args; run bootcmd_fitconf; run bootcmd_load; run bootcmd_run; reset
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/renesas-ota-bootfiles.bb b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/renesas-ota-bootfiles.bb
deleted file mode 100644
index d46f4d885..000000000
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/renesas-ota-bootfiles.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-DESCRIPTION = "Boot files (bootscripts etc.) for Renesas RCar-M3 board"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-inherit deploy
-
-COMPATIBLE_MACHINE = "(salvator-x|m3ulcb|h3ulcb|ebisu)"
-
-S = "${WORKDIR}"
-
-SRC_URI:append:sota = " file://uEnv-ota-m3ulcb.txt \
- file://uEnv-ota-h3ulcb.txt \
- file://uEnv-ota-h3-salvator-xs \
- file://uEnv-ota-m3-salvator-xs"
-do_deploy() {
- install -d ${DEPLOYDIR}/${PN}
-}
-
-do_deploy:append:sota() {
- install -m 0755 ${WORKDIR}/uEnv-ota-${BOARD_NAME}.txt ${DEPLOYDIR}/${PN}/uEnv.txt
-}
-
-addtask deploy before do_package after do_install
-do_deploy[dirs] += "${DEPLOYDIR}/${PN}"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
diff --git a/meta-agl-bsp/virtualization-layer/recipes-extended/xen/files/0001-XEN-on-RPi4-1GB-lmitation-workaround-XEN-tries-to-al.patch b/meta-agl-bsp/virtualization-layer/recipes-extended/xen/files/0001-XEN-on-RPi4-1GB-lmitation-workaround-XEN-tries-to-al.patch
deleted file mode 100644
index d83c65257..000000000
--- a/meta-agl-bsp/virtualization-layer/recipes-extended/xen/files/0001-XEN-on-RPi4-1GB-lmitation-workaround-XEN-tries-to-al.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 2701d65271686dff0cb39ab7da1e821f5dede61e Mon Sep 17 00:00:00 2001
-From: Leonid Lazarev <leonid.lazarev@mera.com>
-Date: Tue, 21 Apr 2020 17:28:16 +0300
-Subject: [PATCH] XEN on RPi4 1GB lmitation workaround: XEN tries to allocated
- the memopry for dom0 within first 4GB, but for some reason raspberry pi only
- allows to load kernel from 1st GB. Push XEN to allocate first bank for dom0
- from 1st GB
-
----
- xen/arch/arm/domain_build.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/xen/arch/arm/domain_build.c b/xen/arch/arm/domain_build.c
-index dd9c3b73ba..8501a8c8aa 100644
---- a/xen/arch/arm/domain_build.c
-+++ b/xen/arch/arm/domain_build.c
-@@ -281,7 +281,7 @@ static void __init allocate_memory_11(struct domain *d,
- */
- while ( order >= min_low_order )
- {
-- for ( bits = order ; bits <= (lowmem ? 32 : PADDR_BITS); bits++ )
-+ for ( bits = order ; bits <= (lowmem ? 30 : PADDR_BITS); bits++ )
- {
- pg = alloc_domheap_pages(d, order, MEMF_bits(bits));
- if ( pg != NULL )
---
-2.17.1
-
diff --git a/meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen-mkimage-rpi4.bb b/meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen-mkimage-rpi4.bb
deleted file mode 100644
index b857cb19f..000000000
--- a/meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen-mkimage-rpi4.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-DESCRIPTION = "Xen hypervisor u-boot image"
-LICENSE = "GPL-2.0-only"
-SECTION = "console/tools"
-
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-
-
-
-ALLOW_EMPTY:${PN} = "1"
-FILES:${PN} = ""
-S = "${WORKDIR}"
-
-DEPENDS = "u-boot-mkimage-native "
-
-# Only for aarch64
-COMPATIBLE_MACHINE = "(-)"
-COMPATIBLE_MACHINE:aarch64 = "(.*)"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-do_configure[noexec] = "1"
-do_deploy[noexec] = "1"
-
-do_compile[depends] += "xen:do_deploy"
-
-# Uboot compatible image
-do_compile () {
- uboot-mkimage -A arm64 -C none -T kernel -a 0x48080000 -e 0x48080000 -n "XEN" -d ${DEPLOY_DIR_IMAGE}/xen-${MACHINE} ${DEPLOY_DIR_IMAGE}/xen-${MACHINE}.uImage
-}
diff --git a/meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen-tools_git.bbappend b/meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen-tools_git.bbappend
deleted file mode 100644
index a67200618..000000000
--- a/meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen-tools_git.bbappend
+++ /dev/null
@@ -1,11 +0,0 @@
-
-# make the package specific to the machine for now
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-# rpi4
-LIC_FILES_CHKSUM:raspberrypi4 = "file://COPYING;md5=4295d895d4b5ce9d070263d52f030e49"
-XEN_REL:raspberrypi4 = "4.13"
-SRCREV:raspberrypi4 = "721f2c323ca55c77857c93e7275b4a93a0e15e1f"
-SRC_URI:raspberrypi4 = " \
- git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \
- "
diff --git a/meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen_git.bbappend b/meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen_git.bbappend
deleted file mode 100644
index 2d63e1841..000000000
--- a/meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen_git.bbappend
+++ /dev/null
@@ -1,18 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-
-# make the package machine-specific
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-# rpi4 specifics
-LIC_FILES_CHKSUM:raspberrypi4 = "file://COPYING;md5=4295d895d4b5ce9d070263d52f030e49"
-XEN_REL:raspberrypi4 = "4.13"
-
-SRCREV:raspberrypi4 = "721f2c323ca55c77857c93e7275b4a93a0e15e1f"
-SRC_URI:append:raspberrypi4 = " file://0001-XEN-on-RPi4-1GB-lmitation-workaround-XEN-tries-to-al.patch"
-
-#due to incorrect xen binary preparation in external library, we add additional deploy
-do_deploy:append:raspberrypi4() {
- if [ -f ${B}/xen/xen ]; then
- install -m 0644 ${B}/xen/xen ${DEPLOYDIR}/xen-${MACHINE}
- fi
-}