summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2023-01-06 18:27:33 +0000
committerScott Murray <scott.murray@konsulko.com>2024-04-18 17:35:39 -0400
commitd6fff288303c2a55547754d033194391ce1aef95 (patch)
tree58b6c523fef5c17c43ae02c7a615076dc7994024
parent4c6db915d18b8a8865d0adede52ba05292dcc6f9 (diff)
Add Yocto Project mickledore release compatibility
Switch to mickledore in LAYERSERIES_COMPAT in layer.conf files. Bug-AGL: SPEC-4578 Change-Id: I6363128896c27a713f7dd59c8a889306a2a04912 Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28366 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-bsp/conf/layer.conf2
-rw-r--r--meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf2
-rw-r--r--meta-agl-core/conf/layer.conf2
-rw-r--r--meta-app-framework/conf/layer.conf2
-rw-r--r--meta-netboot/conf/layer.conf2
-rw-r--r--meta-pipewire/conf/layer.conf2
6 files changed, 6 insertions, 6 deletions
diff --git a/meta-agl-bsp/conf/layer.conf b/meta-agl-bsp/conf/layer.conf
index ba6d0bbec..b9b5d506a 100644
--- a/meta-agl-bsp/conf/layer.conf
+++ b/meta-agl-bsp/conf/layer.conf
@@ -23,4 +23,4 @@ BBFILE_COLLECTIONS += "aglbsp"
BBFILE_PATTERN_aglbsp = "^${LAYERDIR}/"
BBFILE_PRIORITY_aglbsp = "60"
-LAYERSERIES_COMPAT_aglbsp = "kirkstone langdale"
+LAYERSERIES_COMPAT_aglbsp = "kirkstone langdale mickledore"
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf b/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
index 1e6c04c7a..95dcaa537 100644
--- a/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
+++ b/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
@@ -15,4 +15,4 @@ BBFILE_COLLECTIONS += "rcar-gen3-cogent"
BBFILE_PATTERN_rcar-gen3-cogent := "^${LAYERDIR}/"
BBFILE_PRIORITY_rcar-gen3-cogent = "7"
-LAYERSERIES_COMPAT_rcar-gen3-cogent = "kirkstone langdale"
+LAYERSERIES_COMPAT_rcar-gen3-cogent = "kirkstone langdale mickledore"
diff --git a/meta-agl-core/conf/layer.conf b/meta-agl-core/conf/layer.conf
index d9ee57dde..6921e41b6 100644
--- a/meta-agl-core/conf/layer.conf
+++ b/meta-agl-core/conf/layer.conf
@@ -20,7 +20,7 @@ BBFILES_DYNAMIC += " \
qt5-layer:${LAYERDIR}/dynamic-layers/meta-qt5/*/*/*.bbappend \
"
-LAYERSERIES_COMPAT_aglcore = "kirkstone langdale"
+LAYERSERIES_COMPAT_aglcore = "kirkstone langdale mickledore"
LAYERDEPENDS_aglcore = "core"
# Sanity check for meta-virtualization layer.
diff --git a/meta-app-framework/conf/layer.conf b/meta-app-framework/conf/layer.conf
index 0d3a21584..5417076cc 100644
--- a/meta-app-framework/conf/layer.conf
+++ b/meta-app-framework/conf/layer.conf
@@ -9,5 +9,5 @@ BBFILE_COLLECTIONS += "meta-app-framework"
BBFILE_PATTERN_meta-app-framework = "^${LAYERDIR}/"
BBFILE_PRIORITY_meta-app-framework = "60"
-LAYERSERIES_COMPAT_meta-app-framework = "kirkstone langdale"
+LAYERSERIES_COMPAT_meta-app-framework = "kirkstone langdale mickledore"
LAYERDEPENDS_meta-app-framework = "core aglcore openembedded-layer"
diff --git a/meta-netboot/conf/layer.conf b/meta-netboot/conf/layer.conf
index 541323310..f890b7d48 100644
--- a/meta-netboot/conf/layer.conf
+++ b/meta-netboot/conf/layer.conf
@@ -9,5 +9,5 @@ BBFILE_COLLECTIONS += "meta-netboot"
BBFILE_PATTERN_meta-netboot = "^${LAYERDIR}/"
BBFILE_PRIORITY_meta-netboot = "60"
-LAYERSERIES_COMPAT_meta-netboot = "kirkstone langdale"
+LAYERSERIES_COMPAT_meta-netboot = "kirkstone langdale mickledore"
LAYERDEPENDS_meta-netboot = "core networking-layer"
diff --git a/meta-pipewire/conf/layer.conf b/meta-pipewire/conf/layer.conf
index 7a19d8eaa..bbbaf0222 100644
--- a/meta-pipewire/conf/layer.conf
+++ b/meta-pipewire/conf/layer.conf
@@ -9,7 +9,7 @@ BBFILE_COLLECTIONS += "meta-pipewire"
BBFILE_PATTERN_meta-pipewire = "^${LAYERDIR}/"
BBFILE_PRIORITY_meta-pipewire = "71"
-LAYERSERIES_COMPAT_meta-pipewire = "kirkstone langdale"
+LAYERSERIES_COMPAT_meta-pipewire = "kirkstone langdale mickledore"
LAYERDEPENDS_meta-pipewire = "openembedded-layer"
#