summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2023-09-23 15:10:05 -0400
committerScott Murray <scott.murray@konsulko.com>2024-04-18 17:35:39 -0400
commite9fd45c7795267b8f4ce2e75622bc20251cae24e (patch)
tree74428f546c6c650efe332698493d60e0139a6a64
parent98cd78aca4090441f4113e3e605230b66fdcb36a (diff)
Add Yocto Project nanbield release compatibility
Switch to nanbield in LAYERSERIES_COMPAT in layer.conf files. Bug-AGL: SPEC-4578 Change-Id: I11b528374d60caa8c62b95b6ef0c857f35b720f6 Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
-rw-r--r--meta-agl-bsp/conf/layer.conf2
-rw-r--r--meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf2
-rw-r--r--meta-agl-core/conf/layer.conf2
-rw-r--r--meta-app-framework/conf/layer.conf2
-rw-r--r--meta-netboot/conf/layer.conf2
-rw-r--r--meta-pipewire/conf/layer.conf2
6 files changed, 6 insertions, 6 deletions
diff --git a/meta-agl-bsp/conf/layer.conf b/meta-agl-bsp/conf/layer.conf
index b9b5d506a..f8e8e06c4 100644
--- a/meta-agl-bsp/conf/layer.conf
+++ b/meta-agl-bsp/conf/layer.conf
@@ -23,4 +23,4 @@ BBFILE_COLLECTIONS += "aglbsp"
BBFILE_PATTERN_aglbsp = "^${LAYERDIR}/"
BBFILE_PRIORITY_aglbsp = "60"
-LAYERSERIES_COMPAT_aglbsp = "kirkstone langdale mickledore"
+LAYERSERIES_COMPAT_aglbsp = "kirkstone langdale mickledore nanbield"
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf b/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
index 95dcaa537..6ff687a77 100644
--- a/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
+++ b/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
@@ -15,4 +15,4 @@ BBFILE_COLLECTIONS += "rcar-gen3-cogent"
BBFILE_PATTERN_rcar-gen3-cogent := "^${LAYERDIR}/"
BBFILE_PRIORITY_rcar-gen3-cogent = "7"
-LAYERSERIES_COMPAT_rcar-gen3-cogent = "kirkstone langdale mickledore"
+LAYERSERIES_COMPAT_rcar-gen3-cogent = "kirkstone langdale mickledore nanbield"
diff --git a/meta-agl-core/conf/layer.conf b/meta-agl-core/conf/layer.conf
index 6921e41b6..352bb1e54 100644
--- a/meta-agl-core/conf/layer.conf
+++ b/meta-agl-core/conf/layer.conf
@@ -20,7 +20,7 @@ BBFILES_DYNAMIC += " \
qt5-layer:${LAYERDIR}/dynamic-layers/meta-qt5/*/*/*.bbappend \
"
-LAYERSERIES_COMPAT_aglcore = "kirkstone langdale mickledore"
+LAYERSERIES_COMPAT_aglcore = "kirkstone langdale mickledore nanbield"
LAYERDEPENDS_aglcore = "core"
# Sanity check for meta-virtualization layer.
diff --git a/meta-app-framework/conf/layer.conf b/meta-app-framework/conf/layer.conf
index 5417076cc..6b4a11ea1 100644
--- a/meta-app-framework/conf/layer.conf
+++ b/meta-app-framework/conf/layer.conf
@@ -9,5 +9,5 @@ BBFILE_COLLECTIONS += "meta-app-framework"
BBFILE_PATTERN_meta-app-framework = "^${LAYERDIR}/"
BBFILE_PRIORITY_meta-app-framework = "60"
-LAYERSERIES_COMPAT_meta-app-framework = "kirkstone langdale mickledore"
+LAYERSERIES_COMPAT_meta-app-framework = "kirkstone langdale mickledore nanbield"
LAYERDEPENDS_meta-app-framework = "core aglcore openembedded-layer"
diff --git a/meta-netboot/conf/layer.conf b/meta-netboot/conf/layer.conf
index f890b7d48..52d5e0a2b 100644
--- a/meta-netboot/conf/layer.conf
+++ b/meta-netboot/conf/layer.conf
@@ -9,5 +9,5 @@ BBFILE_COLLECTIONS += "meta-netboot"
BBFILE_PATTERN_meta-netboot = "^${LAYERDIR}/"
BBFILE_PRIORITY_meta-netboot = "60"
-LAYERSERIES_COMPAT_meta-netboot = "kirkstone langdale mickledore"
+LAYERSERIES_COMPAT_meta-netboot = "kirkstone langdale mickledore nanbield"
LAYERDEPENDS_meta-netboot = "core networking-layer"
diff --git a/meta-pipewire/conf/layer.conf b/meta-pipewire/conf/layer.conf
index bbbaf0222..43abdf093 100644
--- a/meta-pipewire/conf/layer.conf
+++ b/meta-pipewire/conf/layer.conf
@@ -9,7 +9,7 @@ BBFILE_COLLECTIONS += "meta-pipewire"
BBFILE_PATTERN_meta-pipewire = "^${LAYERDIR}/"
BBFILE_PRIORITY_meta-pipewire = "71"
-LAYERSERIES_COMPAT_meta-pipewire = "kirkstone langdale mickledore"
+LAYERSERIES_COMPAT_meta-pipewire = "kirkstone langdale mickledore nanbield"
LAYERDEPENDS_meta-pipewire = "openembedded-layer"
#