summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2023-05-01 15:07:47 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-05-08 09:56:05 +0000
commit118bda5b1d3f68c93e442b4901d8d8b8cacf545a (patch)
tree85846c552b1edd54a24fa0e6e40d1fdbee8b5983
parent7a9f9802ae2f57535ad3244526c3cec9056b33c2 (diff)
meta-agl-bsp/core: mesa: generic patches should be y-c-l safe
SPEC-4724 added a generic backported patch to mesa. But instead of adding it directly to mesa_%.bbappend, it should have been added to mesa_agl.inc which is only active when "aglcore" feature is enabled, making it yocto-check-layer safe. Bug-AGL: SPEC-4723 Change-Id: I226cba14de917f6e4109d1dc1df364cb74e7ee45 Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28741 Reviewed-by: Marius Vlad <marius.vlad@collabora.com> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account (cherry picked from commit f006538eaecfd0f6130797d7bb4dc59c4e2ecb97) Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28770 Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_%.bbappend2
-rw-r--r--meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_agl.inc2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_%.bbappend b/meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_%.bbappend
index 27dd78371..fb797a436 100644
--- a/meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_%.bbappend
+++ b/meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,5 +1,3 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-SRC_URI += "file://0001-virgl-don-t-a-use-staging-when-a-resources-created-w.patch"
-
require ${@bb.utils.contains('AGL_FEATURES', 'aglcore', '${BPN}_agl.inc', '', d)}
diff --git a/meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_agl.inc b/meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_agl.inc
index e74761317..c0f5b271d 100644
--- a/meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_agl.inc
+++ b/meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_agl.inc
@@ -1,3 +1,5 @@
+SRC_URI += "file://0001-virgl-don-t-a-use-staging-when-a-resources-created-w.patch"
+
# The gallium-llvm is recommended as software 3D graphics renderer
GALLIUM_LLVM = "gallium-llvm"
PACKAGECONFIG:append:qemux86 = " gallium ${GALLIUM_LLVM}"