summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2023-05-01 15:01:57 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-05-08 09:57:49 +0000
commit294f09f89d6f8417345407335ed7d17c512ecf61 (patch)
tree1d9ce70ecc5c770b3e3547d9d799fb91488165f0
parentf78dd2828b5c76cbabb3b57454549faa3ccb7576 (diff)
meta-ti-bsp: ti-sgx-ddk-um: drop systemd service workaround
Latest TI graphics package uses udev rules to initialize the driver and does not install legacy SysVinit rc.pvr script unless udev isn't available. No need for systemd service workaround anymore. Bug-AGL: SPEC-4723 Change-Id: I3ce5d270357578086152d87fb2cf91512691e1a9 Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28740 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> (cherry picked from commit b5e66768b3dcb5fe9ae5b5eed030f8b507b0d5b3) Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28771 Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um/pvr.service19
-rw-r--r--meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend18
2 files changed, 0 insertions, 37 deletions
diff --git a/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um/pvr.service b/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um/pvr.service
deleted file mode 100644
index 1acb94fd4..000000000
--- a/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um/pvr.service
+++ /dev/null
@@ -1,19 +0,0 @@
-[Unit]
-Description=PVR service
-SourcePath=/etc/ti-sgx/rc.pvr
-DefaultDependencies=no
-Before=psplash-start.service
-
-[Service]
-Type=forking
-Restart=no
-TimeoutSec=5min
-IgnoreSIGPIPE=no
-KillMode=process
-GuessMainPID=no
-RemainAfterExit=yes
-ExecStart=/etc/ti-sgx/rc.pvr start
-ExecStop=/etc/ti-sgx/rc.pvr stop
-
-[Install]
-WantedBy=sysinit.target
diff --git a/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend b/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend
deleted file mode 100644
index 86e353414..000000000
--- a/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend
+++ /dev/null
@@ -1,18 +0,0 @@
-FILESEXTRAPATHS:append := ":${THISDIR}/${PN}"
-FILES:${PN} += "/etc/ti-sgx/"
-
-SRC_URI:append = "\
- file://pvr.service \
-"
-
-inherit systemd
-
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE:${PN} = "pvr.service"
-
-do_install:append() {
- install -d ${D}${systemd_system_unitdir}
- install -m 0755 ${WORKDIR}/pvr.service ${D}${systemd_system_unitdir}
- install -d ${D}${sysconfdir}/ti-sgx
- install -m 0755 ${D}${sysconfdir}/init.d/rc.pvr ${D}${sysconfdir}/ti-sgx
-}