summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2024-12-23 00:39:10 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2025-01-10 10:55:29 +0000
commit7c0bc807a43d1d970f6c020e4f44c3439c7ba312 (patch)
treec980d26a497422240381275fd2a81034931ca8e5
parent9ee94d820b4ae198806e781b3519eef42c9f9c8e (diff)
Reduce debug message on UART console
The VisionFive2 board enables debug option in bootargs. As a result, many systemd jounal log output to serial console. It's too noisy for debugging. This patch remove debug and unnessesally option from bootargs. Bug-AGL: SPEC-5328 Change-Id: Iea51dda267f2b1000381e3cd04b62691b308b4db Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/30702 Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-bsp/riscv-layer/recipes-bsp/u-boot/u-boot-starfive/uEnv-visionfive2.txt22
-rw-r--r--meta-agl-bsp/riscv-layer/recipes-bsp/u-boot/u-boot-starfive_%.bbappend1
2 files changed, 23 insertions, 0 deletions
diff --git a/meta-agl-bsp/riscv-layer/recipes-bsp/u-boot/u-boot-starfive/uEnv-visionfive2.txt b/meta-agl-bsp/riscv-layer/recipes-bsp/u-boot/u-boot-starfive/uEnv-visionfive2.txt
new file mode 100644
index 000000000..dac31bf6b
--- /dev/null
+++ b/meta-agl-bsp/riscv-layer/recipes-bsp/u-boot/u-boot-starfive/uEnv-visionfive2.txt
@@ -0,0 +1,22 @@
+# This is the sample jh7110_uEnv.txt file for starfive visionfive U-boot
+# The current convention (SUBJECT TO CHANGE) is that this file
+# will be loaded from the third partition on the
+# MMC card.
+#devnum=1
+partnum=3
+
+# The FIT file to boot from
+fitfile=fitImage
+
+# for debugging boot
+bootargs_ext=if test ${devnum} = 0; then setenv bootargs "console=ttyS0,115200 rootwait root=/dev/mmcblk0p4"; else setenv bootargs "console=ttyS0,115200 rootwait root=/dev/mmcblk1p4"; fi;
+
+# for addr info
+fileaddr=0xa0000000
+fdtaddr=0x46000000
+# boot Linux flat or compressed 'Image' stored at 'kernel_addr_r'
+kernel_addr_r=0x40200000
+
+bootwait=setenv _delay ${bootdelay}; echo ${_delay}; while test ${_delay} > 0; do sleep 1; setexpr _delay ${_delay} - 1; echo ${_delay}; done
+
+boot2=run bootargs_ext; mmc dev ${devnum}; fatload mmc ${devnum}:${partnum} ${fileaddr} ${fitfile}; bootm ${fileaddr} \ No newline at end of file
diff --git a/meta-agl-bsp/riscv-layer/recipes-bsp/u-boot/u-boot-starfive_%.bbappend b/meta-agl-bsp/riscv-layer/recipes-bsp/u-boot/u-boot-starfive_%.bbappend
new file mode 100644
index 000000000..8dead1283
--- /dev/null
+++ b/meta-agl-bsp/riscv-layer/recipes-bsp/u-boot/u-boot-starfive_%.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/u-boot-starfive:"