summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/conf
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-06-12 15:15:17 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-20 10:53:32 +0000
commit45edb36ac263a9c09ab9d3964cc58b648ed82af0 (patch)
treef1852d5dc9ddbf30bc41b24fa7c9a5ba99a62cb7 /meta-agl-bsp/conf
parentfa766117b90a216e9903ee12ede779e66b55e546 (diff)
meta-agl-bsp: Changes to get imx6qdlsabreauto working with etnaviv
Update imx6qdlsabreauto configuration to use open source etnaviv GPU driver instead of Vivante. The previously required weston-ini-conf has been removed as it is not required with etnaviv, and a bbappend has been added for the linux-fslc kernel that this configuration uses so it will pull in the AGL kernel bits. Additionally, the kernel configuration for linux-fslc is tweaked with config fragments to better match the other AGL platforms. Bug-AGL: SPEC-1674, SPEC-2502 Change-Id: Ic40d310b48405ccc7d1435f0fc9f162a129cffe9 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-bsp/conf')
-rw-r--r--meta-agl-bsp/conf/include/agl_imx6qdlsabreauto.inc26
1 files changed, 11 insertions, 15 deletions
diff --git a/meta-agl-bsp/conf/include/agl_imx6qdlsabreauto.inc b/meta-agl-bsp/conf/include/agl_imx6qdlsabreauto.inc
index 44d41c15e..b3658af3c 100644
--- a/meta-agl-bsp/conf/include/agl_imx6qdlsabreauto.inc
+++ b/meta-agl-bsp/conf/include/agl_imx6qdlsabreauto.inc
@@ -1,20 +1,16 @@
DISTRO_FEATURES_append = " agl-medium-arm-compiler"
-# Caution: Hand-merge needed when original recipes are updated
-#
-# Here we only have selected lines from the following (and
-# their included) files
-#
-# fslc-wayland.conf
-# fsl-image-multimedia-full.bb
-#
+# This disables the Freescale/NXP Vivante GPU driver and enables
+# etnaviv support.
+MACHINEOVERRIDES .= ":use-mainline-bsp"
-# fix build error
-SECURITY_CFLAGS_pn-devil = "${SECURITY_NO_PIE_CFLAGS}"
+# Disable the meta-freescale weston-init bbappend as it conflicts
+# with AGL's.
+BBMASK = "meta-freescale/recipes-graphics/wayland/weston-init"
-# since krogoth, u-boot-fslc does not seem to handle imx6qsabreauto correctly
-PREFERRED_PROVIDER_u-boot = "u-boot-imx"
-PREFERRED_PROVIDER_virtual/bootloader = "u-boot-imx"
-PREFERRED_PROVIDER_u-boot-mxsboot-native = "u-boot-imx"
+# Set CMA size large enough to work with AGL
+UBOOT_EXTLINUX_KERNEL_ARGS_append = " cma=512M"
-#PREFERRED_VERSION_weston_mx6_forcevariable = "2.0.0"
+# Generate WIC image also
+AGL_EXTRA_IMAGE_FSTYPES = "wic.xz wic.bmap wic.xz.sha256sum"
+AGL_DEFAULT_INITRAMFS_FSTYPES := ""