summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/conf
diff options
context:
space:
mode:
authorBechir Mghirbi <bechir.mghirbi@grammer.com>2019-03-22 08:00:38 +0100
committerBechir Mghirbi <mghirbi.bechir@gmail.com>2019-04-23 19:31:49 +0000
commit54e9bf9eda7d668df5d71dcc5974c22db5e3eecb (patch)
tree94dbe8b260cb2740e243d71dc61a2a454b698b14 /meta-agl-bsp/conf
parentcfc5a8fdce67a750e5e786ee51907abdedf86249 (diff)
Fix imx6qdlsabreauto machine configuration
The imx6qsabreauto target was falling behind and could not be build for GG-7.0. The commit 808fff5 from 'AGL-repo' removed reference to external repos meta-freescale-3rdparty and meta-freescale-distro. However 'meta-agl' was not updated to follow up on this change which broke configuration for imx6 based targets. This patch makes the required changes to fix the imx6qsabreauto machine configuration: - removes reference to deleted layers: meta-freescale-3rdparty and meta-freescale-distro - updates MACHINE value to imx6qdlsabreauto as defined in meta-freescale layer - deletes reference to packagegroup-fscl-* not required to build AGL - add "agl-medium-arm-compiler" to DISTRO_FEATURES so DEFAULTTUNE is correctly set to 'armv7athf-neon' v2 (jsmoeller): moved board name to match MACHINE v3 (bechir.mghirbi): - remove wayland_2.0.0 as weston_4.0.0.imx is used. - use default IMAGE_FSTYPES as bitbake is complaining that no IMAGE_CMD defined for IMAGE_FSTYPES entry 'sdcard' - Add CFG80211 Kernel configuration Change-Id: Ib8b1d254972c737725247a5b13ce333e8ef9d4dc Signed-off-by: Bechir Mghirbi <bechir.mghirbi@grammer.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/conf')
-rw-r--r--meta-agl-bsp/conf/include/agl_imx6qdlsabreauto.inc20
-rw-r--r--meta-agl-bsp/conf/include/agl_imx6qsabreauto.inc47
2 files changed, 20 insertions, 47 deletions
diff --git a/meta-agl-bsp/conf/include/agl_imx6qdlsabreauto.inc b/meta-agl-bsp/conf/include/agl_imx6qdlsabreauto.inc
new file mode 100644
index 000000000..44d41c15e
--- /dev/null
+++ b/meta-agl-bsp/conf/include/agl_imx6qdlsabreauto.inc
@@ -0,0 +1,20 @@
+DISTRO_FEATURES_append = " agl-medium-arm-compiler"
+
+# Caution: Hand-merge needed when original recipes are updated
+#
+# Here we only have selected lines from the following (and
+# their included) files
+#
+# fslc-wayland.conf
+# fsl-image-multimedia-full.bb
+#
+
+# fix build error
+SECURITY_CFLAGS_pn-devil = "${SECURITY_NO_PIE_CFLAGS}"
+
+# since krogoth, u-boot-fslc does not seem to handle imx6qsabreauto correctly
+PREFERRED_PROVIDER_u-boot = "u-boot-imx"
+PREFERRED_PROVIDER_virtual/bootloader = "u-boot-imx"
+PREFERRED_PROVIDER_u-boot-mxsboot-native = "u-boot-imx"
+
+#PREFERRED_VERSION_weston_mx6_forcevariable = "2.0.0"
diff --git a/meta-agl-bsp/conf/include/agl_imx6qsabreauto.inc b/meta-agl-bsp/conf/include/agl_imx6qsabreauto.inc
deleted file mode 100644
index d1febfb40..000000000
--- a/meta-agl-bsp/conf/include/agl_imx6qsabreauto.inc
+++ /dev/null
@@ -1,47 +0,0 @@
-# Caution: Hand-merge needed when original recipes are updated
-#
-# Here we only have selected lines from the following (and
-# their included) files
-#
-# fslc-wayland.conf
-# fsl-image-multimedia-full.bb
-#
-
-# fslc-wayland.conf
-
-#
-# Followings were intentionally removed from the original recipe
-# to make our set simpler
-#
-# gtk+3-demo clutter-1.0-examples
-#
-
-IMAGE_INSTALL_append = " \
- packagegroup-fsl-tools-gpu \
- packagegroup-fsl-gstreamer1.0 \
- packagegroup-imx-tools-audio \
- weston weston-init weston-examples \
-"
-
-# fsl-image-multimedia-full.bb
-
-IMAGE_INSTALL_append = " \
- packagegroup-fsl-gstreamer1.0-full \
-"
-
-# fix build error
-
-SECURITY_CFLAGS_pn-devil = "${SECURITY_NO_PIE_CFLAGS}"
-
-# since krogoth, u-boot-fslc does not seem to handle imx6qsabreauto correctly
-
-PREFERRED_PROVIDER_u-boot = "u-boot-imx"
-PREFERRED_PROVIDER_virtual/bootloader = "u-boot-imx"
-PREFERRED_PROVIDER_u-boot-mxsboot-native = "u-boot-imx"
-
-# force generate sdcard image also
-
-AGL_DEFAULT_IMAGE_FSTYPES = "sdcard.xz"
-AGL_DEFAULT_INITRAMFS_FSTYPES := ""
-
-PREFERRED_VERSION_weston_mx6_forcevariable = "2.0.0"