summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend
diff options
context:
space:
mode:
authorTom Rini <trini@konsulko.com>2017-11-03 15:29:15 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-22 10:07:25 +0000
commit9691b89fd8a0014b7d57c9fc35cf75bfe8da1577 (patch)
tree0cbc41ae0a0c0d4a38e5952f4678c0831fbe6cb7 /meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend
parent5692de99c4e04d51a6c5da86fea1710d55420873 (diff)
Rework Linux Kernel fragment applications
- All kernel recipes must inherit linux-agl.inc - All kernel recipes for a given version (e.g. 4.9) should include linux-VER-agl.inc in order to avoid duplication (such as the SMACK label patch or security fixes) - We enforce having merge_config.sh be invoked at the end, in order to make sure fragments will be applied. - Add a new fragment for Raspberry Pi to ensure the Pi Touchscreen is still enabled. With all of the above, we fix a number of minor issues as well, such as platforms manually enabling NBD/RAMDISK for netboot as the previous logic was not working in all cases. Bug-AGL: SPEC-946 Change-Id: Ic688e899df5861d83712af12d8e1c6c3c9643300 Signed-off-by: Tom Rini <trini@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/12063 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: José Bollo <jobol@nonadev.net> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend')
-rw-r--r--meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend34
1 files changed, 1 insertions, 33 deletions
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend
index 5dbd457df..88ac94b15 100644
--- a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend
+++ b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend
@@ -1,33 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-DEPENDS += "kern-tools-native"
-
-# Enable support for AR9271
-SRC_URI_append = " file://ath9k_htc.cfg"
-
-# Enable support for Bluetooth HCI USB devices
-SRC_URI_append = " file://btusb.cfg"
-
-# Enable support for Bluetooth HCI USB devices
-SRC_URI_append = " file://btusb.cfg"
-
-# Enable support for HID multitouch
-SRC_URI_append = " file://hid.cfg"
-
-# Enable support for RTLSDR
-SRC_URI_append = " file://rtl_sdr.cfg"
-
-# returns all the elements from the src uri that are .cfg files
-def find_cfgs(d):
- sources=src_patches(d, True)
- sources_list=[]
- for s in sources:
- if s.endswith('.cfg'):
- sources_list.append(s)
-
- return sources_list
-
-do_configure_prepend () {
- cp -a ${WORKDIR}/defconfig .config
- merge_config.sh -m .config ${@" ".join(find_cfgs(d))}
-} \ No newline at end of file
+require recipes-kernel/linux/linux-agl.inc