summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend
diff options
context:
space:
mode:
authorNathan Illerbrun <nathani@validmanufacturing.com>2017-01-05 13:46:13 -0800
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-01 16:08:46 +0000
commit8b24197f0938106afb6811a1848f5d5f3bef4237 (patch)
tree405deafbf77495ce2c93a6588e3f9577a75a02ba /meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend
parent496925b6a16444c816b3ea24b6de4e53650084e6 (diff)
Append kernel recipe to support config fragments and add common kernel config fragments
Add machine template for nitrogen6x Change-Id: I63df939008a36d125f80d74d461453c63386e24e Signed-off-by: Nathan Illerbrun <nathani@validmanufacturing.com>
Diffstat (limited to 'meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend')
-rw-r--r--meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend
new file mode 100644
index 000000000..ab9db0183
--- /dev/null
+++ b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend
@@ -0,0 +1,35 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+# Enable support for AR9271
+SRC_URI_append = " file://ath9k_htc.cfg"
+
+# Enable support for Bluetooth HCI USB devices
+SRC_URI_append = " file://btusb.cfg"
+
+# Enable support for Bluetooth HCI USB devices
+SRC_URI_append = " file://btusb.cfg"
+
+# Enable support for HID multitouch
+SRC_URI_append = " file://hid.cfg"
+
+# Enable support for RTLSDR
+SRC_URI_append = " file://rtl_sdr.cfg"
+
+# Set security default to SMACK
+SRC_URI_append = " file://smack.cfg"
+SRC_URI_append = " file://smack-default-lsm.cfg"
+
+# returns all the elements from the src uri that are .cfg files
+def find_cfgs(d):
+ sources=src_patches(d, True)
+ sources_list=[]
+ for s in sources:
+ if s.endswith('.cfg'):
+ sources_list.append(s)
+
+ return sources_list
+
+do_configure_prepend () {
+ cp -a ${WORKDIR}/defconfig .config
+ merge_config.sh -m .config ${@" ".join(find_cfgs(d))}
+} \ No newline at end of file