summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-core
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-01-10 21:58:37 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-01-10 21:06:19 +0000
commit64ae1f87f3058e365f8076c50912b6f73d8d2067 (patch)
treed523d05e6cd09e2315b48b727e170fe8f6ad0382 /meta-agl-bsp/meta-core
parent14500480dba58433fef05fbf413881fe10593953 (diff)
Add fix for gnutls which is not in morty, yet
This fix was posted here for master, but not yet submitted to morty: https://patchwork.openembedded.org/patch/133002/ Change-Id: I51a279347c1d652e3a9335c0680d2ac4bcff6cf6 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-core')
-rw-r--r--meta-agl-bsp/meta-core/recipes-support/gnutls/files/check_SYS_getrandom.patch35
-rw-r--r--meta-agl-bsp/meta-core/recipes-support/gnutls/gnutls_3.5.3.bbappend8
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-core/recipes-support/gnutls/files/check_SYS_getrandom.patch b/meta-agl-bsp/meta-core/recipes-support/gnutls/files/check_SYS_getrandom.patch
new file mode 100644
index 000000000..535c22af1
--- /dev/null
+++ b/meta-agl-bsp/meta-core/recipes-support/gnutls/files/check_SYS_getrandom.patch
@@ -0,0 +1,35 @@
+From f26c3979ab0325edb2e410d287bc501cf00e0ac0 Mon Sep 17 00:00:00 2001
+From: Nikos Mavrogiannopoulos <nmav@redhat.com>
+Date: Mon, 22 Aug 2016 16:32:34 +0200
+Subject: [PATCH] rnd-linux: added check for SYS_getrandom being defined
+
+This allows to compile the getrandom() code in old Linux systems
+which do not have the system call defined.
+---
+
+Upstream-Status: Backport
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+ lib/nettle/rnd-linux.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/lib/nettle/rnd-linux.c b/lib/nettle/rnd-linux.c
+index d7f07a6..7a24d05 100644
+--- a/lib/nettle/rnd-linux.c
++++ b/lib/nettle/rnd-linux.c
+@@ -56,7 +56,11 @@ static dev_t _gnutls_urandom_fd_rdev = 0;
+ # else
+ # include <sys/syscall.h>
+ # undef getrandom
+-# define getrandom(dst,s,flags) syscall(SYS_getrandom, (void*)dst, (size_t)s, (unsigned int)flags)
++# if defined(SYS_getrandom)
++# define getrandom(dst,s,flags) syscall(SYS_getrandom, (void*)dst, (size_t)s, (unsigned int)flags)
++# else
++# define getrandom(dst,s,flags) -1
++# endif
+ # endif
+
+ static unsigned have_getrandom(void)
+--
+libgit2 0.24.0
+
diff --git a/meta-agl-bsp/meta-core/recipes-support/gnutls/gnutls_3.5.3.bbappend b/meta-agl-bsp/meta-core/recipes-support/gnutls/gnutls_3.5.3.bbappend
new file mode 100644
index 000000000..dc67743fc
--- /dev/null
+++ b/meta-agl-bsp/meta-core/recipes-support/gnutls/gnutls_3.5.3.bbappend
@@ -0,0 +1,8 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/files"
+
+SRC_URI_append = "\
+ file://check_SYS_getrandom.patch \
+ "
+
+
+# backport from https://patchwork.openembedded.org/patch/133002/