aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-2.0.0/0006-Link-compositor-to-egl.patch
diff options
context:
space:
mode:
authorMihail Grigorov <michael.grigorov@konsulko.com>2017-10-13 11:24:56 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-14 13:51:44 +0000
commitf1d3961d6c86983fab125897c2db8892100d2c12 (patch)
tree15b395b3ba8a215843a15aeb6a6130482eff2ab9 /meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-2.0.0/0006-Link-compositor-to-egl.patch
parent6195e19a0925c6cefdf00e4b4d1b9f4f93d10030 (diff)
meta-agl-bsp: imx6: Add EGL support for iMX6 in Weston 2.0
In Weston 2.0, the EGL support was dropped from the fbdev-backend, as that was not the correct way to initialize EGL. However, the vendor support patches in Weston 1.11 still require that functionality. Restore the EGL support in the fbdev-backend, until the issue is resolved, by either adding a standalone backend, or switching to etnaviv. Bug-AGL: SPEC-905 Change-Id: I9fc00e35c2eefee07998053e1fccec6265ac3b9e Signed-off-by: Mihail Grigorov <michael.grigorov@konsulko.com> Signed-off-by: Georgi Vlaev <georgi.vlaev@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/11305 Reviewed-by: Leon Anavi <leon.anavi@konsulko.com> Reviewed-by: Thomas Rini <trini@konsulko.com> Reviewed-by: Matt Porter <mporter@konsulko.com> Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-2.0.0/0006-Link-compositor-to-egl.patch')
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-2.0.0/0006-Link-compositor-to-egl.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-2.0.0/0006-Link-compositor-to-egl.patch b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-2.0.0/0006-Link-compositor-to-egl.patch
new file mode 100644
index 000000000..3cad74fd4
--- /dev/null
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-2.0.0/0006-Link-compositor-to-egl.patch
@@ -0,0 +1,12 @@
+Index: weston-1.11.1/configure.ac
+===================================================================
+--- weston-1.11.1.orig/configure.ac 2016-11-08 17:26:14.266564760 -0600
++++ weston-1.11.1/configure.ac 2016-11-09 19:38:58.000000000 -0600
+@@ -93,6 +93,7 @@
+ PKG_CHECK_MODULES(EGL, [egl glesv2])
+ PKG_CHECK_MODULES([EGL_TESTS], [egl glesv2 wayland-client wayland-egl])
+ PKG_CHECK_MODULES([GL_RENDERER], [libdrm])
++ COMPOSITOR_MODULES="$COMPOSITOR_MODULES egl"
+ fi
+
+ AC_ARG_ENABLE(xkbcommon,