summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-freescale-layer/recipes-graphics
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-05-23 17:48:49 -0400
committerScott Murray <scott.murray@konsulko.com>2023-05-31 15:02:18 +0000
commit54917638ddc412483cb6ea54431977a5ebc01981 (patch)
treec05c8fe5843384c5fb5acdc24de56c7da4f6513a /meta-agl-bsp/meta-freescale-layer/recipes-graphics
parent89143beca6c66882c3ac9a9de4ab811ce5b620b5 (diff)
Fix up i.MX8MQ EVK configuration
Changes: - Since linux-fslc-lts does not boot on the EVK at the moment, and both it and linux-fslc still do not have support for the HDMI output, switch back to using linux-fslc-imx with tweaks to use etnaviv as we did pre-kirkstone. - A bbappend has been added for linux-fslc-lts since that was missed in a previous upgrade, and even though we are not using it now, it is possibly useful for other i.MX variants. - A machine template for using the NXP BSP with the Vivante GPU driver, imx8mq-evk-viv, has been restored, as testing shows it now works with the current panel-less homescreens. As before, the intent of this configuration is for testing or as an example of potential production use of meta-freescale where NXP support is available. - Start up of Bluetooth support has been disabled, as it currently causes kernel oopses or panics (both have been seen in testing). This happens with both machine templates. SPEC-4807 has been opened to track this issue. Bug-AGL: SPEC-4799 Change-Id: I38e4e720643714541efb0fed08d5ab64545bb02d Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28937 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-freescale-layer/recipes-graphics')
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_10.0.1.imx.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_10.0.1.imx.bbappend b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_10.0.1.imx.bbappend
new file mode 100644
index 000000000..07a43f958
--- /dev/null
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_10.0.1.imx.bbappend
@@ -0,0 +1,10 @@
+# Work around PACKAGECONFIG:remove of "x11 wayland" added to the recipe
+# in meta-freescale commit 5a5c5dd. This can be removed once the issue
+# has been resolved by a revert of that breakage upstream.
+# What is done below is effectively a disabling of the "wayland"
+# PACKAGECONFIG option and then open coding what its effects would
+# normally be, since the :remove prevents specifying it in the usual way.
+PACKAGECONFIG[wayland] = ""
+DEPENDS:append = " virtual/egl virtual/libgles2"
+PACKAGECONFIG_CONFARGS:append = " -Dbackend-wayland=true"
+