summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-intel/recipes-kernel/linux-firmware
diff options
context:
space:
mode:
authorRonan <ronan.lemartret@iot.bzh>2017-01-09 14:24:10 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-01-10 19:39:32 +0000
commitf33718a8d0be1e39ce2b3f6a527aa805ccd8df22 (patch)
tree2682928c3576b4051434e6ece79bc821278e8b80 /meta-agl-bsp/meta-intel/recipes-kernel/linux-firmware
parentbab7debd03d46733ff39ce86b2221f5387b36019 (diff)
fix intel build for linux-firmware
Change-Id: I565bdf1ac23b19bbdc65401cd0843f8a8de1b2b7 Signed-off-by: Ronan <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl-bsp/meta-intel/recipes-kernel/linux-firmware')
-rw-r--r--meta-agl-bsp/meta-intel/recipes-kernel/linux-firmware/linux-firmware_git.bbappend11
1 files changed, 0 insertions, 11 deletions
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux-firmware/linux-firmware_git.bbappend b/meta-agl-bsp/meta-intel/recipes-kernel/linux-firmware/linux-firmware_git.bbappend
index 58e198e6e..d7052afae 100644
--- a/meta-agl-bsp/meta-intel/recipes-kernel/linux-firmware/linux-firmware_git.bbappend
+++ b/meta-agl-bsp/meta-intel/recipes-kernel/linux-firmware/linux-firmware_git.bbappend
@@ -1,14 +1,3 @@
-LIC_FILES_CHKSUM_remove = "file://LICENSE.amdgpu;md5=a8592c24c2672062e03c7392fc7fe3bc"
-LIC_FILES_CHKSUM_remove = "file://LICENSE.radeon;md5=6c7f97c6c62bdd9596d0238bb205118c"
-LIC_FILES_CHKSUM_remove = "file://WHENCE;md5=2ec7cdcaf7b1f57b77665b4d77b76e50"
-LIC_FILES_CHKSUM += "\
- file://LICENSE.amdgpu;md5=3fe8a3430700a518990c3b3d75297209 \
- file://LICENSE.radeon;md5=69612f4f7b141a97659cb1d609a1bde2 \
- file://WHENCE;md5=fc7f8a9fce11037078e90df415baad71 \
-"
-
-SRCREV = "cccb6a0da98372bd66787710249727ad6b0aaf72"
-
LICENSE_${PN}-ibt-license = "Firmware-ibt_firmware"
LICENSE_${PN}-ibt-11-5 = "Firmware-ibt_firmware"
FILES_${PN}-ibt-license = "/lib/firmware/LICENCE.ibt_firmware"
background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
#! /usr/bin/python3
# -*- coding: utf-8 -*-
#
#  Copyright 2016 RĂ©mi Duraffort <remi.duraffort@linaro.org>
#
#  This program is free software; you can redistribute it and/or modify
#  it under the terms of the GNU General Public License as published by
#  the Free Software Foundation; either version 2 of the License, or
#  (at your option) any later version.
#
#  This program is distributed in the hope that it will be useful,
#  but WITHOUT ANY WARRANTY; without even the implied warranty of
#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
#  GNU General Public License for more details.
#
#  You should have received a copy of the GNU General Public License
#  along with this program; if not, write to the Free Software
#  Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston,
#  MA 02110-1301, USA.
#

import argparse
import zmq.auth


def main():
    """
    Parse options and create the certificate
    """
    parser = argparse.ArgumentParser(description="")
    parser.add_argument("--directory", type=str,
                        default="/etc/lava-dispatcher/certificates.d",
                        help="Directory where to store the certificates")
    parser.add_argument(type=str, dest="name",
                        help="Name of the certificate")
    args = parser.parse_args()

    # Create the certificate
    print("Creating the certificate in %s" % args.directory)
    zmq.auth.create_certificates(args.directory, args.name)
    print(" - %s.key" % args.name)
    print(" - %s.key_secret" % args.name)


if __name__ == '__main__':
    main()