aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-03-06 22:30:21 +0000
committerGerrit Code Review <gerrit@automotivelinux.org>2018-03-06 22:30:21 +0000
commit1144907f57b9a57e5235ef201de2b6633d23f834 (patch)
tree5cacb29d261facef56b0b17a9c386440e26539e9 /meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend
parent9bda1264f34b9b2250fea50cf4895bf0ff818028 (diff)
parent8c0f97cdd12f30dc30291bacf9bdf8a928fb4a55 (diff)
Merge "enabling kernel 4.14"
Diffstat (limited to 'meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend')
-rw-r--r--meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend
new file mode 100644
index 000000000..c49b8ecb0
--- /dev/null
+++ b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend
@@ -0,0 +1,20 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+# adding most supported USB Bluetooth, Wifi, and Ethernet devices
+SRC_URI_append = " file://usb-devices.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/usb-devices.cfg"
+
+# adding support for other graphic cards to work on more PC HW
+SRC_URI_append = " file://extra-graphic-devices.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/extra-graphic-devices.cfg"
+
+# adding internal network in kernel for network boot
+SRC_URI_append = " file://net-devices.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/net-devices.cfg"
+
+# Ensure we have a startup.nsh file
+SRC_URI_append = " file://startup.nsh"
+
+do_deploy_append() {
+ install -m 0755 ${WORKDIR}/startup.nsh ${DEPLOYDIR}/
+}