aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend
diff options
context:
space:
mode:
authorCorentin Labbe <clabbe@baylibre.com>2019-04-12 13:11:44 +0000
committerCorentin Labbe <clabbe@baylibre.com>2019-04-15 08:33:42 +0000
commit1c5e1f26af6e8b91115b45630902381051468dfa (patch)
treeb8c0849524e3cc22c180c40faf82c5358f26ed38 /meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend
parentfea01d98626fa0f030f87a7f0efbe2d94bb45de8 (diff)
meta-intel: Support the upsquare board
This patch adds the necessary CONFIG for booting the upsquare board. The upsquare have an R8169 ethernet card and need it built-in for the kernel DHCP autoconf to work. The upsquare need some MFD_INTEL configs to boot. The meta-intel miss some CONFIG necessary for LAVA and NBD to works. Bug-AGL: SPEC-2075 Change-Id: I990732c78b53ac591dde83f4e372b420ea558fa7 Signed-off-by: Corentin Labbe <clabbe@baylibre.com>
Diffstat (limited to 'meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend')
-rw-r--r--meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend
index 62c264d12..e159747ae 100644
--- a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend
+++ b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend
@@ -12,6 +12,14 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/extra-graphic-devices.cfg"
SRC_URI_append = " file://net-devices.cfg"
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/net-devices.cfg"
+# adding specific driver needed by the upsquare board
+SRC_URI_append = " file://upsquare.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/upsquare.cfg"
+
+# adding CONFIG needed by LAVA and NBD
+SRC_URI_append = " file://lava.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/lava.cfg"
+
# Ensure we have a startup.nsh file
SRC_URI_append = " file://startup.nsh"