summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb
diff options
context:
space:
mode:
authorAndrey Shamanin <andrei.shamanin@orioninc.com>2020-07-07 14:09:45 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-07-20 14:30:32 +0000
commit0326ee5c14813694df3c026217abaa7c78539a0a (patch)
tree5b23db7922f98050489c952044cd3a4cef1fb8f7 /meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb
parente5310229bf79f12d34e3d3595f9880261d02648c (diff)
Add AWS embedded C SDK
AWS embedded C SDK allows to create applications for communication with AWS cloud. Commit includes a new recipe and patches for AWS SDK compilation. Fix review comment (use mbedTLS from external recipes). Bug-AGL: SPEC-3479 Signed-off-by: Andrey Shamanin <andrei.shamanin@orioninc.com> Change-Id: I0d4923cd8541e7be89580b32ed6c68fcb10c1ce7 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/24950 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb')
-rw-r--r--meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb b/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb
new file mode 100644
index 000000000..a3f67004e
--- /dev/null
+++ b/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "AWS IoT device SDK for embedded C"
+AUTHOR = "AWS"
+HOMEPAGE = "https://github.com/aws/aws-iot-device-sdk-embedded-C"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=acc7a1bf87c055789657b148939e4b40"
+
+SRC_URI = "\
+ git://github.com/aws/aws-iot-device-sdk-embedded-C.git;protocol=https \
+ file://Makefile.aws \
+ file://aws_iot_config.h \
+ file://awsiotsdk.pc \
+"
+SRCREV = "d039f075e1cc2a2a7fc20edc6868f328d8d36b2f"
+
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+DEPENDS = "mbedtls"
+RDEPENDS_${PN} += "mbedtls"
+
+do_configure_prepend() {
+ cp ${WORKDIR}/Makefile.aws ${S}/src
+ cp ${WORKDIR}/aws_iot_config.h ${S}/include
+ cp ${WORKDIR}/awsiotsdk.pc ${S}
+}
+
+do_compile() {
+ cd ${S}/src
+ oe_runmake -f ./Makefile.aws DESTDIR=${D} all
+}
+
+do_install() {
+ cd ${S}/src
+ oe_runmake -f ./Makefile.aws DESTDIR=${D} install
+}
+
+BBCLASSEXTEND = "native nativesdk"
+
+ALLOW_EMPTY_${PN} = "1"
+