summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-qcom/recipes-bsp
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-02-14 10:54:52 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-02-14 10:54:52 +0100
commitb6dc44f585b839ab1a2f0133b74958037fe1cb64 (patch)
tree5025d5422e79e229c255e886cf1bd177ec11f37d /meta-agl-bsp/meta-qcom/recipes-bsp
parent88a162a657936f14e8e1ac5d6a0c3b368d0e9a45 (diff)
parent07d0d613cbca9619e3ad5361d39ae0feafbcb168 (diff)
Merge remote-tracking branch 'agl/sandbox/locust2001/rocko' into HEAD
* agl/sandbox/locust2001/rocko: (33 commits) most: remove skb_put_data patch from SRC_URI linux-linaro-qcomlt: update to kernel 4.14 dragonboard-410c: update 96boards-tools recipe dragonboard-410c: remove ACCEPT_EULA setting 00_local.conf.agl.inc: Disable GObject Introspection Data linux-ti-staging: Remove linux-dtb.inc geoclue: Remove unnecessary dependency u-boot-ota: Fix build error with gcc7 linux-firmware: Remove duplicated lines Change image type to wic.vmdk glibc: Arrange patch file netboot.bbclass: Remove image_types_uboot inheritance meta-agl-bsp/classes: Remove bbclass files rygel: Arrange rocko security-manager: Fix build error that causes gcc v7.0 cynara: Fix build error that causes gcc v7.0 libcap: Fix warning mesa: Arrange the recipe libmicrohttpd: Remove the recipe connman: Arrange patch file ... Bug-AGL: SPEC-1181 Change-Id: I8fa84553664fd3d7495b42c7198744f05eebcce0 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-qcom/recipes-bsp')
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.11.bb (renamed from meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.7.bb)9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.7.bb b/meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.11.bb
index 36a983198..5c3583526 100644
--- a/meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.7.bb
+++ b/meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.11.bb
@@ -5,16 +5,18 @@ SECTION = "devel"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-SRCREV = "193f355823d9dc38f370759153ac950a2833b0e2"
+SRCREV = "395b5994a5fa52f9db10f480fce74e9acdbe3318"
SRC_URI = "git://github.com/96boards/96boards-tools;branch=master;protocol=https"
S = "${WORKDIR}/git"
-inherit systemd allarch
+inherit systemd allarch update-rc.d
do_install () {
install -d ${D}${sysconfdir}/udev/rules.d
install -m 0755 ${S}/*.rules ${D}${sysconfdir}/udev/rules.d/
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${S}/resize-disk ${D}${sysconfdir}/init.d/
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${S}/resize-helper.service ${D}${systemd_unitdir}/system
@@ -23,5 +25,8 @@ do_install () {
install -m 0755 ${S}/resize-helper ${D}${sbindir}
}
+INITSCRIPT_NAME = "resize-disk"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
+
SYSTEMD_SERVICE_${PN} = "resize-helper.service"
RDEPENDS_${PN} += "e2fsprogs-resize2fs gptfdisk parted util-linux udev"