summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
diff options
context:
space:
mode:
authorKotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>2017-02-23 21:25:27 +0900
committerKotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>2017-02-24 03:10:29 +0000
commit496925b6a16444c816b3ea24b6de4e53650084e6 (patch)
tree5ab0438bda0bb79664bb4955b2869bcd214077fd /meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
parentecea85c853214fa4c67811f5066f894582e1d7c2 (diff)
weston: Set XDG_RUNTIME_DIR for qcom
Without this environment variable, Weston fails to start on Dragonboard * backport from master commit 0a34b88c4b661a91962dd0c04c3af7e582bafcbd Change-Id: I67ad6ec7cb2ad4cdcf0885e42d0b297d87ec43d3 Signed-off-by: Kotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>
Diffstat (limited to 'meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend')
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
new file mode 100644
index 000000000..8fff1dfe7
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
@@ -0,0 +1,20 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+SRC_URI_append = "\
+ file://weston-qcom.ini \
+ file://weston.sh \
+ "
+
+do_install_append() {
+ WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
+ install -d ${D}${WESTON_INI_CONFIG}
+ install -m 0644 ${WORKDIR}/weston-qcom.ini ${D}${WESTON_INI_CONFIG}/weston.ini
+
+ install -d ${D}/${sysconfdir}/profile.d
+ install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
+}
+
+FILES_${PN} += " \
+ ${sysconfdir}/xdg/weston/weston.ini \
+ ${sysconfdir}/profile.d/weston.sh \
+ "