summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-qcom/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bbappend
diff options
context:
space:
mode:
authorKotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>2017-02-23 21:22:17 +0900
committerKotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>2017-02-24 03:10:17 +0000
commitecea85c853214fa4c67811f5066f894582e1d7c2 (patch)
treefdb59c24f73620622fd5b4360262a049237db0be /meta-agl-bsp/meta-qcom/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bbappend
parent2cfbf533cd367a2dc7974001365622d6ff4b0787 (diff)
Fix issue with bluetooth pairing
This patch is ported from meta-agl-extra. * backport from master commit 99804790f0954fc2cf0d20aa4d0a581361d3cfe6 Change-Id: I851783e83d37d161c83f87422df5b2d592d6dda3 Signed-off-by: Kotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>
Diffstat (limited to 'meta-agl-bsp/meta-qcom/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bbappend')
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bbappend25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-qcom/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bbappend b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bbappend
new file mode 100644
index 000000000..62f8d7c3e
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/linux-linaro-qcomlt_4.4.bbappend
@@ -0,0 +1,25 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+# smack patches for handling bluetooth
+SRC_URI_append_smack = "\
+ file://0001-Smack-File-receive-for-sockets.patch \
+ file://0002-smack-fix-cache-of-access-labels.patch \
+ file://0003-Smack-ignore-null-signal-in-smack_task_kill.patch \
+ file://0004-Smack-Assign-smack_known_web-label-for-kernel-thread.patch \
+"
+
+# Extra configuration options
+SRC_URI += "file://smack.cfg \
+ file://smack-default-lsm.cfg \
+ file://fanotify.cfg \
+ file://uinput.cfg \
+ file://hid.cfg "
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/smack.cfg ${WORKDIR}/smack-default-lsm.cfg ${WORKDIR}/fanotify.cfg ${WORKDIR}/uinput.cfg ${WORKDIR}/hid.cfg"
+
+# Enable support for TP-Link TL-W722N USB Wifi adapter
+SRC_URI += " file://ath9k_htc.cfg "
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/ath9k_htc.cfg"
+
+# Enable support for RTLSDR
+SRC_URI += " file://rtl_sdr.cfg "
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/rtl_sdr.cfg"