summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi/recipes-graphics/mesa/mesa_12.0.3.bb
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@gmail.com>2017-04-26 18:04:24 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-04-26 16:10:47 +0000
commit349a5fe4ff40e953a669b7acea7ecb8e9b3053c3 (patch)
treed4692761ad6f0f0abcd2267abfae66219597a840 /meta-agl-bsp/meta-raspberrypi/recipes-graphics/mesa/mesa_12.0.3.bb
parent5450a1b55c723da5d222be4cec0253d100844c62 (diff)
meta-agl-bsp/meta-raspberrypi: Upgrade to v12.0.3
Yocto morty has mesa 12.0.1 but it has a bug for vc4 driver. The bug is fixed in v12.0.2 and yocto upstream provides v12.0.3. This commit is taking from https://github.com/GENIVI/meta-genivi-dev/commit/e9c013951feb5c78519da04513ab79baf400264e. Bug-AGL: SPEC-445 Change-Id: Idfd0878f3549c20eac77ae680a65347ec851bd94 Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/9253 Reviewed-by: Changhyeok Bae <changhyeok.bae@lge.com> Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi/recipes-graphics/mesa/mesa_12.0.3.bb')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/mesa/mesa_12.0.3.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/mesa/mesa_12.0.3.bb b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/mesa/mesa_12.0.3.bb
new file mode 100644
index 000000000..acc8353dd
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/mesa/mesa_12.0.3.bb
@@ -0,0 +1,17 @@
+require ${BPN}.inc
+
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/mesa-${PV}.tar.xz \
+ file://replace_glibc_check_with_linux.patch \
+ file://disable-asm-on-non-gcc.patch \
+"
+
+SRC_URI[md5sum] = "1113699c714042d8c4df4766be8c57d8"
+SRC_URI[sha256sum] = "1dc86dd9b51272eee1fad3df65e18cda2e556ef1bc0b6e07cd750b9757f493b1"
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+ if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+ sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
+}