summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi/recipes-graphics/mesa/mesa_19.1.6.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2019-09-19 11:45:02 +0300
committerLeon Anavi <leon.anavi@konsulko.com>2019-09-19 11:45:02 +0300
commit4fddfd6871c5ad0effac23ff69014250c6f24879 (patch)
tree6c5b07cec144b7cff5eaec575117703407897842 /meta-agl-bsp/meta-raspberrypi/recipes-graphics/mesa/mesa_19.1.6.bb
parenta1c325e0820709e656ee54709a320afd9640f596 (diff)
mesa: Upgrade Mesa for Raspberry Pi 4
Bring Mesa 19.1.6 to meta-agl-bsp/meta-raspberrypi because there are driver issues with Mesa 18.1 for Raspberry Pi 4. The recipes for this new version are coming from the master branch of layer openembedded-core. With the newer version of Mesa Weston works fine on Raspberry Pi 4 and the home screen appears as expected. Bug-AGL: SPEC-2656 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Change-Id: I0d4f6e6fdff3c6ac54a72d19abfc292efcea7a3f
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi/recipes-graphics/mesa/mesa_19.1.6.bb')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/mesa/mesa_19.1.6.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/mesa/mesa_19.1.6.bb b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/mesa/mesa_19.1.6.bb
new file mode 100644
index 000000000..19221e9e2
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/mesa/mesa_19.1.6.bb
@@ -0,0 +1,20 @@
+require ${BPN}.inc
+
+SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
+ file://0001-meson.build-check-for-all-linux-host_os-combinations.patch \
+ file://0002-meson.build-make-TLS-GLX-optional-again.patch \
+ file://0003-Allow-enable-DRI-without-DRI-drivers.patch \
+ "
+
+SRC_URI[md5sum] = "7dbb40b8d10e89bee0a5bfc85350647b"
+SRC_URI[sha256sum] = "2a369b7b48545c6486e7e44913ad022daca097c8bd937bf30dcf3f17a94d3496"
+
+UPSTREAM_CHECK_GITTAGREGEX = "mesa-(?P<pver>\d+(\.\d+)+)"
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+ if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+ sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
+}