summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi/recipes-graphics
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-04-12 14:07:33 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-04-19 11:18:50 +0000
commit029de35a172da31b083b86d93a79d787773dec11 (patch)
treed49ead563efec4f599900dd4abfca4c4dd14476a /meta-agl-bsp/meta-raspberrypi/recipes-graphics
parent473b4354758ea6657fd196c30fb14332b5e7178d (diff)
Use weston-init to startup weston
* weston.service should not be a part of weston recipes * remove weston.service from AGL weston recipes * yocto upstream uses the recipe weston-init to startup weston * customize weston-start with sed - remove openvt - add option to weston-launch * customize weston.service with sed - add option for weston * unified the weston startup beteween AGL BSPs * remove fix on the AGL BSP Bug-AGL: SPEC-452 Bug-AGL: SPEC-310 Change-Id: I12722826abdc004214d289961e900c36528ec6e3 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi/recipes-graphics')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston.sh7
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend14
2 files changed, 0 insertions, 21 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston.sh b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston.sh
deleted file mode 100644
index 225a034bb..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-if test -z "$XDG_RUNTIME_DIR"; then
- export XDG_RUNTIME_DIR=/run/user/$UID
- mkdir --parents $XDG_RUNTIME_DIR
- chmod 0700 $XDG_RUNTIME_DIR
-fi
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
deleted file mode 100644
index f8c0a5fa3..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
+++ /dev/null
@@ -1,14 +0,0 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
-
-SRC_URI_append = "\
- file://weston.sh \
- "
-
-do_install_append() {
- install -d ${D}/${sysconfdir}/profile.d
- install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
-}
-
-FILES_${PN} += " \
- ${sysconfdir}/profile.d/weston.sh \
- "
eral.Number.Hex */ .highlight .mi { color: #0000DD; font-weight: bold } /* Literal.Number.Integer */ .highlight .mo { color: #0000DD; font-weight: bold } /* Literal.Number.Oct */ .highlight .sa { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Affix */ .highlight .sb { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Backtick */ .highlight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
#!/bin/bash

OUTFILENAME="Gitbook-Iotbzh-template"

SCRIPT=$(basename $BASH_SOURCE)

function usage() {
	cat <<EOF >&2
Usage: $SCRIPT [options] [pdf|serve|doxygen]

Options:
   --debug
      enable debug when generating pdf or html documentation
   -d|--dry
      dry run
   -h|--help
      get this help

Example:
	$SCRIPT pdf

EOF
	exit 1
}

function info() {
	echo "$@" >&2
}

#default values
DEBUG_FLAG=""
DRY=""
DO_ACTION=""
OUT_DIR=./build

[[ $? != 0 ]] && usage
while [ $# -gt 0 ]; do
	case "$1" in
		--debug) DEBUG_FLAG="--log=debug --debug";;
		-d|--dry) DRY=echo;;
		-h|--help) usage;;
        pdf | serve | doxygen) DO_ACTION=$1;;
		--) break;;
	esac
    shift
done

cd $(dirname $0)
ROOTDIR=`pwd -P`

# Create out dir if needed
[ -d $OUT_DIR ] || mkdir -p $OUT_DIR

if [ "$DO_ACTION" = "pdf" -o "$DO_ACTION" = "serve" ]; then
    GITBOOK=`which gitbook`
    [ "$?" = "1" ] && { echo "You must install gitbook first, using: sudo npm install -g gitbook-cli"; exit 1; }

    EBCONV=`which ebook-convert`
    [ "$?" = "1" ] && { echo "You must install calibre first, using: 'sudo apt install calibre' or refer to https://calibre-ebook.com/download"; exit 1; }

    if [ "$DO_ACTION" = "pdf" ]; then

        # Update cover when book.json has been changed
        [[ $ROOTDIR/book.json -nt $ROOTDIR/docs/cover.jpg ]] && { echo "Update cover files"; $ROOTDIR/docs/resources/make_cover.sh || exit 1; }

	    OUTFILE=$OUT_DIR/$OUTFILENAME.pdf
        $DRY $GITBOOK pdf $ROOTDIR $OUTFILE $DEBUG_FLAG
        [ "$?" = "0" ] && echo "PDF has been successfully generated in $OUTFILE"
    else
        $DRY $GITBOOK serve $DEBUG_FLAG
    fi

elif [ "$DO_ACTION" = "doxygen" ]; then
    $DRY cd $OUT_DIR && cmake .. && make doxygen $ROOTDIR/Doxyfile

else
    echo "Unknown action !"
    usage
fi