summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2018-08-07 17:12:16 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-08-14 12:56:59 +0000
commite2377bbd16d6c8c01591ea3c91355e21c03f1bde (patch)
treed6561d3170f9b50a1b88b4301aab2728aa4fae68 /meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
parent798bdbdcdf351da854626d9c47d543293cb8004a (diff)
linux-firmware: Enable WiFi for Raspberry Pi 3 B+
Add binary blobs for brcmfmac43455 to enable WiFi for the new Raspberry Pi 3 Model 3 B+. At the moment meta-raspberrypi provides this for latest releases but not for Rocko. This fix should remain in meta-agl until AGL moves to sumo or until we backport the required changes to meta-raspberrypi branch rocko. Bug-AGL: SPEC-1652 Change-Id: I644938ac3799b0e831f022fff9b2bc85aa8fd27c Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux-firmware/linux-firmware_%.bbappend')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux-firmware/linux-firmware_%.bbappend26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux-firmware/linux-firmware_%.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
new file mode 100644
index 000000000..6042c4197
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
@@ -0,0 +1,26 @@
+FILESEXTRAPATHS_prepend_rpi := "${THISDIR}/files:"
+
+SRC_URI_append_rpi = " \
+ file://brcmfmac43455-sdio.bin \
+ file://brcmfmac43455-sdio.clm_blob \
+ file://brcmfmac43455-sdio.txt \
+"
+
+do_install_append_rpi() {
+ install -d ${D}${nonarch_base_libdir}/firmware/brcm/
+
+ # Replace outdated linux-firmware files with updated ones from
+ # raspbian firmware-nonfree. Raspbian adds blobs and nvram
+ # definitions that are also necessary so copy those too.
+ for fw in brcmfmac43455-sdio ; do
+ install -m 0644 ${WORKDIR}/${fw}.* ${D}${nonarch_base_libdir}/firmware/brcm/
+ done
+}
+
+LICENSE_${PN}-bcm43455 = "Firmware-broadcom_bcm43xx"
+
+FILES_${PN}-bcm43455 = " \
+ ${nonarch_base_libdir}/firmware/brcm/brcmfmac43455-sdio.* \
+"
+
+RDEPENDS_${PN}-bcm43455 += "${PN}-broadcom-license"