summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0002-Disable-DMA-in-sdhci-driver.patch
diff options
context:
space:
mode:
authorPaul Barker <pbarker@konsulko.com>2021-01-12 11:38:20 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-01-12 16:57:45 +0000
commit8395c5513a6fd133d47a92f88f92ebeacf8183e5 (patch)
treec07d6d5d5a6539caece1be3fff135b3414cd869f /meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0002-Disable-DMA-in-sdhci-driver.patch
parent67248e369aac29a94797f2f6bb52ee162f6ca378 (diff)
linux-raspberrypi: Tidy patches & config fragments
Move all patches and config fragments into the linux-raspberrypi subdirectory to remove confusion and warnings seen for non-4.19 kernel versions: WARNING: .../bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.14.bb: Unable to get checksum for linux-raspberrypi SRC_URI entry 0001-mconf-menuconfig.patch: file could not be found WARNING: .../bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb: Unable to get checksum for linux-raspberrypi SRC_URI entry 0001-mconf-menuconfig.patch: file could not be found Bug-AGL: SPEC-3760 Cc: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Signed-off-by: Paul Barker <pbarker@konsulko.com> Change-Id: Iccb9efcd8240f28437e3494bd008dc9aca649c4e Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25887 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0002-Disable-DMA-in-sdhci-driver.patch')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0002-Disable-DMA-in-sdhci-driver.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0002-Disable-DMA-in-sdhci-driver.patch b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0002-Disable-DMA-in-sdhci-driver.patch
new file mode 100644
index 000000000..04a8733f2
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0002-Disable-DMA-in-sdhci-driver.patch
@@ -0,0 +1,25 @@
+From 758bc9b917469bc4e527dc3aae821c91cbc3d426 Mon Sep 17 00:00:00 2001
+From: Stewart Hildebrand <stewart.hildebrand@dornerworks.com>
+Date: Thu, 18 Jul 2019 00:01:27 -0400
+Subject: [PATCH 2/4] Disable DMA in sdhci driver
+
+---
+ drivers/mmc/host/sdhci-iproc.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/drivers/mmc/host/sdhci-iproc.c b/drivers/mmc/host/sdhci-iproc.c
+index 983cddce9..150f7bfc8 100644
+--- a/drivers/mmc/host/sdhci-iproc.c
++++ b/drivers/mmc/host/sdhci-iproc.c
+@@ -252,6 +252,8 @@ static const struct sdhci_iproc_data bcm2835_data = {
+
+ static const struct sdhci_pltfm_data sdhci_bcm2838_pltfm_data = {
+ .ops = &sdhci_iproc_32only_ops,
++ .quirks = SDHCI_QUIRK_BROKEN_DMA |
++ SDHCI_QUIRK_BROKEN_ADMA,
+ };
+
+ static const struct sdhci_iproc_data bcm2838_data = {
+--
+2.17.1
+