summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-01-06 01:26:50 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-01-06 10:54:03 +0000
commitfb57dd647f577b5df40380c6f3996443bbe0cf8b (patch)
tree6b42f2cce75559cdecdc3e34ab6738d2916ff9ef /meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend
parent5dbfea7fd40a029a5067dd9800c3205addd6b798 (diff)
Apply bluetooth/smack patches also to rpi kernelchinook_3.0.0chinook/3.0.03.0.0
This changeset patches the rpi with the needed changes to allow bluetooth to work together with smack. The patches were developed for porter and are a backport of patches submitted for 4.10+ . Bug-AGL: SPEC-293 Change-Id: I96d04a709de6ad7843840d9ae154f041173948a2 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend
index e5cdb2aff..a2b2a42f2 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend
@@ -8,6 +8,18 @@ SRC_URI_append = "\
${@base_conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
"
+#-------------------------------------------------------------------------
+# smack patches for handling bluetooth
+
+SRC_URI_append_smack = "\
+ file://0001-Smack-File-receive-for-sockets.patch \
+ file://0002-smack-fix-cache-of-access-labels.patch \
+ file://0003-Smack-ignore-null-signal-in-smack_task_kill.patch \
+ file://0004-Smack-Assign-smack_known_web-label-for-kernel-thread.patch \
+"
+
+
+
do_configure_append_smack() {
# SMACK and Co
kernel_configure_variable IP_NF_SECURITY m