summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-03-24 11:16:21 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-30 07:36:39 +0000
commit7d1d7457ff2b71abe95525b26148d5a3e7a42790 (patch)
treec7b9796ea099f94da5b879276235fea6077d6bf4 /meta-agl-bsp/meta-raspberrypi
parent64d59ff0e0e835a53445b07257d3896fb48abfb5 (diff)
Generate weston.ini dynamically
* remove weston-intel.ini * add new package weston-ini-conf * the list of the sections of weston.ini is described in variable flags WESTONSECTION * each section is described in variable flags WESTONSECTION * each output screen is described in agl_screen variable Bug-AGL: SPEC-477 Change-Id: I3d25ab49018e3842c916993ba8b9bcc2428d5170 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend4
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini19
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend6
3 files changed, 4 insertions, 25 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
new file mode 100644
index 000000000..14b858d45
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -0,0 +1,4 @@
+# Disable LVDS
+WESTONOUTPUT2[agl_screen] ??= "SCREEN_DSI"
+
+WESTONSECTION[WESTONOUTPUT2] = "output"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini
deleted file mode 100644
index 15721e3dc..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini
+++ /dev/null
@@ -1,19 +0,0 @@
-[core]
-backend=drm-backend.so
-shell=ivi-shell.so
-
-[ivi-shell]
-ivi-module=ivi-controller.so
-ivi-input-module=ivi-input-controller.so
-
-# HDMI / GeChic
-[output]
-name=HDMI-A-1
-transform=270
-# Uncomment for 1080p on GeChic 1502i:
-#mode=173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
-
-# official touchscreen over DSI interface
-[output]
-name=DSI-1
-transform=270
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
index 7c8167961..f8c0a5fa3 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
@@ -1,20 +1,14 @@
FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append = "\
- file://weston-raspberrypi.ini \
file://weston.sh \
"
do_install_append() {
- WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
- install -d ${D}${WESTON_INI_CONFIG}
- install -m 0644 ${WORKDIR}/weston-raspberrypi.ini ${D}${WESTON_INI_CONFIG}/weston.ini
-
install -d ${D}/${sysconfdir}/profile.d
install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
}
FILES_${PN} += " \
- ${sysconfdir}/xdg/weston/weston.ini \
${sysconfdir}/profile.d/weston.sh \
"