summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/renesas-ota-bootfiles.bb
diff options
context:
space:
mode:
authorAnton Gerasimov <tossel@gmail.com>2018-09-05 15:17:45 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-11-30 19:31:41 +0000
commitc2b2edbd68d2074a8c9010dd6270ebdeef763375 (patch)
treea405b927c45ab41dfedad0bf41cef2ec7e852be4 /meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/renesas-ota-bootfiles.bb
parentf6585ce144bee5cc847990408366104984c73826 (diff)
Enable agl-sota for h3ulcb
Change-Id: I3c2d0df6e3afd4aa0671261f7d143ac15d88a836 Signed-off-by: Anton Gerasimov <tossel@gmail.com>
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/renesas-ota-bootfiles.bb')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/renesas-ota-bootfiles.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/renesas-ota-bootfiles.bb b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/renesas-ota-bootfiles.bb
new file mode 100644
index 000000000..f247ef743
--- /dev/null
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/renesas-ota-bootfiles.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Boot files (bootscripts etc.) for Renesas RCar-M3 board"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+inherit deploy
+
+COMPATIBLE_MACHINE = "(m3ulcb|h3ulcb)"
+
+S = "${WORKDIR}"
+
+SRC_URI_append_sota = "file://uEnv-ota-m3ulcb.txt \
+ file://uEnv-ota-h3ulcb.txt"
+
+do_deploy() {
+ install -d ${DEPLOYDIR}/${PN}
+}
+
+do_deploy_append_sota() {
+ install -m 0755 ${WORKDIR}/uEnv-ota-${BOARD_NAME}.txt ${DEPLOYDIR}/${PN}/uEnv.txt
+}
+
+addtask deploy before do_package after do_install
+do_deploy[dirs] += "${DEPLOYDIR}/${PN}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+