summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-12-21 08:46:01 +0000
committerGerrit Code Review <gerrit@automotivelinux.org>2017-12-21 08:46:02 +0000
commit27cac0e75c2c9c40ac6955c4dc4aef5171907013 (patch)
tree3223c29908e69c79b91475221c69bfc966ec8ea2 /meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot
parentaffcab4d4682ab2b2db9d64425c7c4956ea6b6b4 (diff)
parent8e1e3e7be522095086e80bd4e1640ca3bb28a3c4 (diff)
Merge changes I6716197b,I07fe2d5a,Ia35a6007,I1457c89a,Iaaf3b308 into eel
* changes: meta-agl-bsp/meta-rcar-gen3: Add u-boot-script-rcar-gen3 to ease boot meta-rcar-gen3: add si46xx radio tools for KF support ti-bt: add a systemd unit and enable meta-rcar-gen3: add WiLink8 tools for KF support templates: rcar3: add meta-rcar-gen3-adas for KF support
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-script-rcar-gen3.bb35
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-script-rcar-gen3/boot.cmd4
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-script-rcar-gen3.bb b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-script-rcar-gen3.bb
new file mode 100644
index 000000000..42a05ec26
--- /dev/null
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-script-rcar-gen3.bb
@@ -0,0 +1,35 @@
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = "u-boot-mkimage-native"
+
+SRC_URI = "file://boot.cmd"
+
+inherit deploy
+
+do_mkimage () {
+ uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
+ -n "boot script" -d ${WORKDIR}/boot.cmd ${WORKDIR}/boot.scr
+}
+
+addtask mkimage after do_compile before do_install
+
+do_compile[noexec] = "1"
+
+do_install () {
+ install -D -m 644 ${WORKDIR}/boot.scr ${D}/boot/boot.scr
+}
+
+do_deploy () {
+ install -D -m 644 ${WORKDIR}/boot.scr \
+ ${DEPLOYDIR}/boot.scr-${MACHINE}-${PV}-${PR}
+
+ cd ${DEPLOYDIR}
+ rm -f boot.scr-${MACHINE}
+ ln -sf boot.scr-${MACHINE}-${PV}-${PR} 6x_bootscript-${MACHINE}
+}
+
+addtask deploy after do_install before do_build
+
+FILES_${PN} += "/"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-script-rcar-gen3/boot.cmd b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-script-rcar-gen3/boot.cmd
new file mode 100644
index 000000000..61a7a925e
--- /dev/null
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-script-rcar-gen3/boot.cmd
@@ -0,0 +1,4 @@
+setenv bootargs console=ttySC0,115200 root=/dev/mmcblk0p1 rootwait ro rootfstype=ext4
+ext4load mmc 0:1 0x48000000 /boot/${fdtfile}
+ext4load mmc 0:1 0x48080000 /boot/Image
+booti 0x48080000 - 0x48000000