summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/mesa/mesa-wayland.inc
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-02-24 10:34:38 +0100
committerRonan Le Martret <ronan.lemartret@iot.bzh>2017-03-19 12:25:48 +0100
commitcbde4c99fd6460f9a1d05b0fa87bc1a0342ac007 (patch)
tree14df28b67c4ccf5d7a38caa2132057ab462e3fb6 /meta-agl-bsp/meta-rcar-gen3/recipes-graphics/mesa/mesa-wayland.inc
parent79079335ceb05a5079f6594e31624375f4abc471 (diff)
[rcar-gen3] Remove mesa backport
* as Renesas rcar gen3 v2.16 do not use mesa recipes (.bbappend) 10.6.3, we do not need to maintain this recipes. Bug-AGL: SPEC-471 Bug-AGL: SPEC-419 Change-Id: I80582d725bec71931d8d5fbf83fe3e0b29381592 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3/recipes-graphics/mesa/mesa-wayland.inc')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-graphics/mesa/mesa-wayland.inc36
1 files changed, 0 insertions, 36 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/mesa/mesa-wayland.inc b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/mesa/mesa-wayland.inc
deleted file mode 100644
index d290c3c73..000000000
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/mesa/mesa-wayland.inc
+++ /dev/null
@@ -1,36 +0,0 @@
-# FIXME: can not override PACKAGECONFIG.
-PACKAGECONFIG[gles] = "--enable-gles1 --disable-gles2"
-PACKAGECONFIG[egl] = "--enable-egl --with-egl-platforms=wayland"
-
-# Disable the gbm modules of mesa
-EXTRA_OECONF_rcar-gen3 := \
- "${@'${EXTRA_OECONF}'.replace('--enable-gbm', '--disable-gbm')}"
-# Remove the gbm and egl packages. These are provided in other recipes.
-PACKAGES_remove_rcar-gen3 = " \
- libgbm-dev libgbm \
- libegl-mesa-dev libegl-mesa \
- libegl-dev libegl \
- libgles2-mesa libgles2-mesa-dev \
-"
-INSTALLED_HEADER = "src/egl/wayland/wayland-egl/wayland-egl-priv.h"
-
-# Remove the x11 configure
-PACKAGECONFIG_rcar-gen3 := "${@'${PACKAGECONFIG}'.replace('x11', '')}"
-
-do_install_append_rcar-gen3() {
- # Remove libegl-mesa modules and headers
- rm -f ${D}/${libdir}/libEGL.la
- rm -f ${D}/${libdir}/libEGL.so*
- rm -f ${D}/${libdir}/pkgconfig/egl.pc
- rm -rf ${D}/${includedir}/EGL
- rm -rf ${D}/${includedir}/KHR
-
- # install required header for wayland
- install -d ${D}/usr/include
- install -m 644 ${S}/${INSTALLED_HEADER} ${D}/usr/include/
-}
-
-FILES_libwayland-egl-dev += " \
- /usr/include \
- /usr/include/*.h \
-"